Troubleshooting
Problem
The Tivoli Storage Manager server fails to start when trying to activate database manager.
Symptom
You may see the following errors when starting server in the foreground.
ANR0172I rdbdb.c(2472): Error encountered performing action ActivateDatabase.
ANR0162W Supplemental database diagnostic information:
:-1042 (SQL1042C An unexpected system error occurred. SQLSTATE=58004
You may also see the following errors in db2diag.log:
2015-05-06-19.30.35.277702+180 E6884672A968 LEVEL: Critical
PID : 12714126 TID : 3086 PROC : db2sysc 0
INSTANCE: tsminst1 NODE : 000 DB : TSMDB1
APPHDL : 0-7 APPID: *LOCAL.tsminst1.150506163035
AUTHID : TSMINST1
EDUID : 3086 EDUNAME: db2agent (TSMDB1) 0
FUNCTION: DB2 UDB, base sys utilities, sqeLocalDatabase::MarkDBBad,
probe:10
MESSAGE : ADM14001C An unexpected and critical error has occurred: "DBMarkedBad". The instance may have been shutdown as a result
Cause
The "bad page" errors seen in the db2diag.log indicate there is possible damage to the DB2 database. There can be many reasons why the database was damaged.
Resolving The Problem
When you encounter these messages, please contact IBM support. We will review the data and provide best way to resolve this problem.
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Document Information
Modified date:
17 June 2018
UID
swg21902591