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IBM Content Collector SMTP Receiver Service Fails to Start.

Troubleshooting


Problem

IBM Content Collector SMTP Receiver service fails to start.

Symptom

IBM Content Collector SMTP Receiver service shuts down immediately after it is started.

Cause

IBM Content Collector SMTP Receiver Remote Manager only runs on default port 4555.

Diagnosing The Problem

  • On the IBM Content Collector, if another application is already using port 4555, then the SMTP Receiver service will fail with the following error in <ICC_INSTALL_DIR>\james\james-2.3.2\logs\phoenix.log.
    For example, in C:\IBM\ContentCollector\james\james-2.3.2\logs\phoenix.log:
    ERROR   2014-09-08 14:52:14.158 [Phoenix.] (): Component named "remotemanager" failed to pass through the Starting stage. (Reason: java.net.BindException: Address already in use: JVM_Bind).

    ERROR   2014-09-08 14:52:14.158 [Phoenix.] (): There was an error running phase "startup" for Block named "remotemanager". (Reason: Component named "remotemanager" failed to pass through the Starting stage. (Reason: java.net.BindException: Address already in use: JVM_Bind).).
    org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleException: Component named "remotemanager" failed to pass through the Starting stage. (Reason: java.net.BindException: Address already in use: JVM_Bind).

  • If the port number of the SMTP Remote Manager component is changed in <ICC_INSTALL_DIR>\james\james-2.3.2\apps\james\SAR-INF\config.xml to use a non-default port number other than 4555, then a different error will be reported in phoenix.log.
    For example, in C:\IBM\ContentCollector\james\james-2.3.2\apps\james\SAR-INF\config.xml, port number is changed to a value other than 4555:

      <remotemanager enabled="true">
         
    <port>4554</port>

    In C:\IBM\ContentCollector\james\james-2.3.2\logs\phoenix.log:

    ERROR   2014-06-23 14:00:54.205 [Phoenix.] (): Component named "smtpserver" failed to pass through the Parameterizing stage.
    (Reason: java.lang.RuntimeException: java.lang.Exception: Severe: There was an error running the SMTP auth update command:

    Jun 23, 2014 2:00:54 PM com.ibm.afu.james.config.JamesTelnetHelper readOutputINFO: TelnetInput: <null>Jun 23, 2014 2:00:54 PM com.ibm.afu.james.config.JamesTelnetHelper readOutputINFO:
    Telnet connection timed out, because of not expected last result
    Jun 23, 2014 2:00:54 PM com.ibm.afu.james.config.JamesTelnetHelper readOutputINFO: Last result: <no result>
    java.lang.NullPointerException

Resolving The Problem

  • Do not change the default port number in <ICC_INSTALL_DIR>\james\james-2.3.2\apps\james\SAR-INF\config.xml.
  • Ensure there is no other application using port 4555 on the IBM Content Collector server.

[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Collector for Email","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;4.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21685451