Troubleshooting
Problem
Adding a second dispatcher to an existing environment resulted in the end users receiving the following error in the browser due to the Presentation service not starting correcting: DPR-ERR-2022 No response generated. This may be due to an incorrect configuration, a damaged installation, or because the dispatcher did not finish initializing.
Symptom
Error captured in cogserver.log file during startup of the dispatcher:
DPR-DPR-1035 Dispatcher detected error. problem starting handler cpsServiceHandlernulljava.lang.NullPointerException at com.cognos.cps.bseries.pogo.ProducerRegistrationHandler.getProducersFromDisk(ProducerRegistrationHandler.java:499)
Suggestion: Provide the full text transcript of the error.
Suggestion: Provide the full text transcript of the error.
Cause
File system permissions were incorrect
Environment
Cognos 10.2 deployed to WebSphere 8.5 on AIX 7.1
Cognos product had been installed using WebSphere account and therefore all permissions on Cognos directory and files were correct.
The install would start successfully using the default Tomcat application server.
Provide a list of the specific components that influence or cause the issue to occur.
Diagnosing The Problem
ipfCPSclientconfig.xml.sample trace captured the following information to indicate there was a permissions problem:
PRS-TPR-0360 A security violation occurred. The path "../system.xml" could not be accessed.
Exception encountered...
Exception Class: com.cognos.xts.XTSException
Exception Key: bootstrap.stopped
Stack dump:
com.cognos.xts.XTSException: bootstrap.stopped at com.cognos.xts.request.AXTSDispatcherHandler.invokeImpl(AXTSDispatcherHandler.java:691)
Resolving The Problem
Root cause was an incorrect File System mount permission. The AIX team had to unmount and then perform a mount of their /www/WebSphere8 to resolve permissions for the WebSphere user account as only root had read permissions.
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Document Information
Modified date:
15 June 2018
UID
swg21685053