IBM Support

Unexpected media wait times for some sessions

Question & Answer


Question

Why are there sessions with several minutes of media wait time when writing to file pool volumes?

Cause

Insufficient volumes available in the storage pool for this FILE device class to accommodate all the sessions that need to write to this sequential media.

Answer

The media wait can occur for a destination storage pool that is using a FILE device type when:

  • The stgpool only uses predefined volumes, and
  • The number of filling/empty volumes in that pool is less than the number of incoming sessions, and
  • Those sessions all need a volume to write the data for a backup/archive
The sessions will first take all the available volumes that can be written to, and then any additional/subsequent sessions will go into a media wait until a prior session completes its use of a volume.

For example:
If a file storage pool has 50 predefined volumes
    40 of these are currently full
    8 are filling
    2 are empty
then there are only 10 volumes that have write capability for the sessions who have this pool as their destination. If a backup process is initiated which starts 20 client backups with the destination of this file pool then only the first 10 will immediately get a volume mounted and can start their backup processing. The other 10 will go into a media wait until one of the first 10 sessions finishes and the volume it was using is then made available.
Note: If the initial session fills the volume then there is even less available volumes for the subsequent sessions to use.

Applications using the Tivoli Storage Manager API (for example the Content Manager application) are subject to encounter this type of situation, as they can initiate numerous sessions, all at the same time.

To avoid sessions writing to a storage pool destination of device type FILE from going into media waits, ensure that there are always writable volumes available. For storage pools that are using predefined volumes, it is necessary to ensure there are enough filling or empty volumes (with readwrite access) defined in the storage pool. Specifically, it is necessary to have at least the number of volumes available which are equal to the maximum number of session that may run at one time. If disk space for FILE storage pool volumes is not an issue, using scratch volumes is another option that would avoid sessions going into a media wait.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21680657