Question & Answer
Question
Why are there sessions with several minutes of media wait time when writing to file pool volumes?
Cause
Insufficient volumes available in the storage pool for this FILE device class to accommodate all the sessions that need to write to this sequential media.
Answer
The media wait can occur for a destination storage pool that is using a FILE device type when:
- The stgpool only uses predefined volumes, and
- The number of filling/empty volumes in that pool is less than the number of incoming sessions, and
- Those sessions all need a volume to write the data for a backup/archive
For example:
If a file storage pool has 50 predefined volumes
- 40 of these are currently full
8 are filling
2 are empty
Note: If the initial session fills the volume then there is even less available volumes for the subsequent sessions to use.
Applications using the Tivoli Storage Manager API (for example the Content Manager application) are subject to encounter this type of situation, as they can initiate numerous sessions, all at the same time.
To avoid sessions writing to a storage pool destination of device type FILE from going into media waits, ensure that there are always writable volumes available. For storage pools that are using predefined volumes, it is necessary to ensure there are enough filling or empty volumes (with readwrite access) defined in the storage pool. Specifically, it is necessary to have at least the number of volumes available which are equal to the maximum number of session that may run at one time. If disk space for FILE storage pool volumes is not an issue, using scratch volumes is another option that would avoid sessions going into a media wait.
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21680657