IBM Support

Server failed to start after upgrade SQL5035N

Troubleshooting


Problem

After a server upgrade, it fails to start with the follwing error: SQL5035N The database must be upgraded to the current release.

Symptom

When trying to start the Tivoli Storage Manager server after an upgrade and you receive the following error:



    ANR9999D_3831306406 ReportSQLDiagInfo(dbieval.c:1568) Thread (5): Missing sqlState=55001, sqlCode=-5035 from table. Returning rc = 9994. SQL5035N The database must be upgraded to the current release. SQLSTATE=55001

Cause

The database instance did not upgrade properly during the upgrade process.

Diagnosing The Problem

Run the following DB2 commands as the Tivoli Storage Manager instance user (default: tsminst1):



    db2start
    db2 connect to tsmdb1

    You will get:
    SQL5035N The database must be upgraded to the current release.
    SQLSTATE=55001

Resolving The Problem

You will need to manually complete the upgrade of the database instance using the commands below:



    db2start
    db2 upgrade database TSMDB1

Note: The upgrade command will take time, depending on how big the database is. There will be no progress messages given. You can monitor the CPU/Memory usage to verify the process is running.

After the upgrade completes, try the DB2 connect commands again and it should be successful.

    db2start
    db2 connect to tsmdb1

Now you can start your Tivoli Storage Manager server.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

IBM Spectrum Protect

Document Information

Modified date:
17 June 2018

UID

swg21669576