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Verify administrators mailbox is not hidden from global address list

Troubleshooting


Problem

How to determine whether your administrators mailbox is hidden from global address list (GAL)?

Symptom

The mailbox restore fails when the logged on administrators mailbox is hidden from GAL.

Cause

The mailbox of the user running a mailbox restore with Data Protection for Exchange must not be hidden from GAL.

Diagnosing The Problem

The hidden status can be checked using Exchange Management shell:

whoami | Get-Mailbox | Where{$_.HiddenFromAddressListsEnabled -eq $true}

In case mailbox is hidden the output looks like:



Name Alias ServerName ProhibitSendQuota
---- ----- ---------- -----------------
Administrator Administrator ExchangeServer unlimited

If mailbox is not hidden, the output is empty.

Resolving The Problem

To make the mailbox visible in GAL:
whoami | Set-Mailbox -HiddenFromAddressListsEnabled $false

[{"Product":{"code":"SSTG2D","label":"Tivoli Storage Manager for Mail"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS Exchange","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3;6.4;7.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21668729