IBM Support

Unable to Add Datasheet (New Row) on Work Order

Troubleshooting


Problem

A user tries to add a datasheet (new row) to a work order and the entire Maximo application freezes.

Cause

The SEED value for PLUSCWODSWODSNUM is incorrect.

Diagnosing The Problem

Run the following queries on the DB to confirm the values:


select * from autokey where autokeyname='PLUSCWODSWODSNUM'
select max(WODSNUM) from PLUSCWODS

Resolving The Problem

Run the following query on your DB to correct the value:
update autokey set seed=VALUE1 where autokeyname='PLUSCWODSWODSNUM'

Ensure the 'VALUE1' above for seed is the same value from the query for max(WODSNUM). Restart the Maximo Application Sever and test again.

[{"Product":{"code":"SSLKZS","label":"Maximo Calibration"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Calibration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"6.5;7.1;7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21668656