IBM Support

Security Bulletin: Reflected Cross-Site Scripting Vulnerability in IBM Content Navigator (CVE-2014-0874)

Security Bulletin


Summary

Reflected Cross-Site Scripting Vulnerability in IBM Content Navigator

Vulnerability Details

CVEID: CVE-2014-0874

DESCRIPTION:
Arbitrary characters inserted into request parameters are not properly encoded. Not encoding user-supplied input may expose a web application to cross-site scripting.

CVSS Base Score: 3.5
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/91002 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:N)

Affected Products and Versions

IBM Content Navigator 2.0.0, 2.0.1, and 2.0.2

IBM Content Navigator is a component that is available to customers in these products (and the products that contain them):

  • IBM Content Manager
  • IBM FileNet Content Manager
  • IBM Content Foundation
  • IBM Content Manager OnDemand

Remediation/Fixes

Version 2.0.0: Upgrade to Content Navigator 2.0.2 and apply fix pack 2.0.2.2-ICN-FP002

Version 2.0.1: Upgrade to Content Navigator 2.0.2 and apply fix pack 2.0.2.2-ICN-FP002

Version 2.0.2: Apply fix pack 2.0.2.2-ICN-FP002

Workarounds and Mitigations

None known, apply fixes

Get Notified about Future Security Bulletins

References

Off

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

[{"Product":{"code":"SSEUEX","label":"Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.0.2;2.0.1;2.0","Edition":"","Line of Business":{"code":"LOB15","label":"Integration"}}]

Document Information

Modified date:
17 June 2018

UID

swg21665362