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ADM1541W ADM1823E messages and Server crashes

Troubleshooting


Problem

ADM1823E The active log is full and is held by application handle "12345..". Terminate this application by COMMIT, ROLLBACK or FORCE APPLICATION

Symptom

The DB2diag.log shows the messages:

    MESSAGE : ADM1541W Application "db2reorg" with application handle
    "0-12345" and application id "*LOCAL.DB2.140115184657" executing under authentication id "TSMINST1" has been forced off of the database for violating database configuration parameter NUM_LOG_SPAN (current value "29"). The unit of work will be rolled back.

    ADM1823E The active log is full and is held by application handle "12345..".
    Terminate this application by COMMIT, ROLLBACK or FORCE APPLICATION


    MESSAGE : ZRC=0x85100009=-2062548983=SQLP_NOSPACE "Log File has reached its saturation point" DIA8309C Log file was full.

The Tivoli Storage Manager Server activity log contains the messages:

    ANR0130E tbrsql.c(1430): Server LOG space exhausted. (PROCESS: 13)
    ANR0162W Supplemental database diagnostic information:
    -1:57011:-964 ([IBM][CLI Driver][DB2/AIX64]
    SQL0964C The transaction log for the database is full. SQLSTATE=57011). (PROCESS: 13)

Cause

There can be various reasons that this failure can be seen. In this case, an uncommitted transaction was using all the DB2 primary and secondary logs.

Resolving The Problem

More information regarding the application holding the lock on the active log space can be obtained from a DB2 snapshot for the application handle:


    db2 get snapshot for application agentid <appl handle>

If this error rarely occurs, the application causing the problem can be forced off. For example:
    db2 force 12345
Where "12345" is the application handle that is shown in the DB2 message.

If the Tivoli Storage Manager Server is running, a backup can be performed to clear the archive logs and free up additional log space.

In most cases this message is indicative of a sizing problem for the DB2 logs, for example if the LOGFILSIZ is too small. The Log size can be increased by adding the ACTIVELOGSize into dsmserv.opt file. For example :
    ACTIVELOGSize 16384
A restart of the TSM Server is necessary to put this updated value into effect. Also ensure that the fix is in place for APAR IC99259 where changes to the ACTIVELOGSIZE might not be honored.

It may also be necessary to increase the number of Primary and/or Secondary log files that are allocated within DB2. These values are held within the DB2 cfg settings LOGPRIMARY and LOGSECOND.

Additionally, the archive log space may be insufficient and needs to be increased.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21663101