IBM Support

MustGather: Diagnostic information for IBM Rational Reporting Development Intelligence and Insight

Troubleshooting


Problem

What information to collect to diagnose and resolve issues involving IBM Rational Reporting Development Intelligence (RRDI) and IBM Rational Insight.

Cause

This MustGather assists you in collecting the data to help you diagnose and resolve the issue. If you cannot determine the root cause using the information collected, open a service request with IBM Support for further investigation.

Resolving The Problem



PROBLEM DETERMINATION
System Information


What is the failing product?

What is the version and release number?

What machine model, operating system, and version are running?
Problem Description


What are the expected results?

What statement or command is being used?

What are the exact symptoms and syntax?

What is or isn’t happening including exact error number and message text? (See must gather for details on gathering logs if none are present)

Is anyone else experiencing the problem?

Is this the first time this operation has been attempted?

Is this the first time this problem has occurred?

When did this activity work last?

What has changed since the activity last worked?

If the problem does not occur every time, under what conditions does the problem not occur?

Is there any other software running on the system which might be conflicting with this product?

Can you reproduce the problem? If so, provide a reproducible test case or instructions on how to reproduce the error condition.




ENVIRONMENT DETAILS
Topology description
Version of CLM
Version of Insight or RRDI (32 or 64-bit)
Version of other tools integrated with CLM, Insight, or RRDI
Operating System Version
Server specs (RAM and CPU)
Database Vendor, Version, Edition (32 or 64-bit)
WebSphere Application Server Version (32 or 64-bit)




RRDI/INSIGHT SETUP WIZARD RELATED MUSTGATHER
Run the setup wizard with TRACE logging enabled
Is this a new install/upgrade?
Is this an All-in-One install or Distributed?
If you are upgrading Insight, was the Jazz namespace previously configured?
What other non Jazz namespaces do you have configured?
    Obtain the following logs/config files:
    · <RRDI_Install>\setup\logs\rrdi_setup.log
    · <RRDI_Install>\cognos\cmplst.txt
    · <RRDI_Install>\cognos\logs\cogserver.log

NOTE: If you run into issues in setup wizard dealing with the WebSphere Application Server (WAS) profile, please see the WebSphere related MustGather




JAZZ NAMESPACE AUTHENTICATION RELATED MUSTGATHER
Obtain the application server logs using this InfoCenter topic
Obtain the following configuration files:
    · <RRDI_Install>\cognos\configuration\jazzns_config.xml
    · <RRDI_Install>\cognos\configuration\AAA.properties
    · <RRDI_Install>\cognos\configuration\cogstartup.xml
    · <WebSphere_Install>\AppServer\profiles\<server>\installedApps\<cell>\IBM Cognos.ear\p2pd.war\WEB-INF\web.xml





EXTRACT-TRANSFROM-LOAD (ETL) RELATED MUSTGATHER
Date and Time of failure
Name of job that was executed
Backup of Data Manager catalog
Obtain the following logs and configuration files:
    · For ETLs run as data movement tasks, <RRDI_Install>\cognos\datamanager\log
    · For ETLs run via Data Manager, <RRDIDevTools_Install>\cognos\datamanager\log
    · The ri_jdbc.log (located in the <user_profile>\logs directory e.g. C:\Users\<username>\logs)
    · If Java ETLs are enabled, a copy of the <app>-etl.log from the CLM server logs directory
NOTE: If the ri_jdbc.log is not in the the <user_profile>\logs directory or that log is not showing entries from the most recent ETL jobs, check the C:\WINDOWS\SysWOW64\config\systemprofile\logs directory.





REPORT SERVER RELATED MUSTGATHER
Date and Time of failure
Run the report SQL directly against the DB. You can find the report SQL by opening the report in Report Studio and going to Tools -> Show Generated SQL...
Screenshot of Personal tab in My Preferences which shows default namespace and permissions that the logged in user has.
Obtain a copy of the following logs and configuration files:
    · <RRDI_Install>\cognos\cmplst.txt
    · <RRDI_Install>\cognos\configuration\jazzns_config.xml
    · <RRDI_Install>\cognos\logs\cogserver.log (as well as backup logs if written to during failure)
    · <RRDI_Install>\cognos\configuration\cogstartup.xml






LICENSING RELATED MUSTGATHER (INSIGHT ONLY)
Version of Rational License Server?
Is your issue already discussed in the Licensing Troubleshooting section of the Insight InfoCenter?
Enable verbose licensing logging using the steps found in this InfoCenter topic
Run the ISALite data collector for IBM Rational Common Licensing




DEVELOPMENT TOOLS RELATED MUSTGATHER
Confirm whether you can access the URIs configured in the Environment section of Cognos Configuration (especially Gateway and Dispatcher for external applications URIs) through a browser on the Dev Tools server.
The cogstartup.xml file from Dev Tools server (<RRDI_Install>\cognos\configuration\cogstartup.xml)
Verify that 32-bit client for database server is installed on the machine.




WEBSPHERE APPLICATION SERVER (WAS) RELATED MUSTGATHER
IBM HTTP Server (IHS)


MustGather: IBM HTTP Server SSL handshake and configuration problems
Application Server (for each app server if multiple)


Download IBM Support Assistant (ISA) Lite for WebSphere Application Server

Provide Trace String for ISALite: “SSL=all”
General


Topology diagram and description

Is there a load balancer in use? If so, what is the type?

Is there a firewall in place? If so, where in the topology is it?

Is the environment clustered?

Is the hosts file being used as opposed to DNS?

Is WAS admin security enabled?
Virtual Host


Is the default virtual host being used?

If not, are multiple hosts defined?
SSL Key Files


How many keys are being used?

Are any key files shared between software (ie – Plugin-cfg.xml and IHS Key file are often shared)
Unix


What is the user starting the HTTP server?




JAZZ RELATED MUSTGATHER
Capture a print screen of https://<server>:<port>admin#action=com.ibm.team.reportsManagement.configureCustomReportsConnection
If CLM 4.0 or higher, execute the ISALite Data Collector for CLM




DATA WAREHOUSE RELATED MUSTGATHER
Which version of CLM or Insight are you upgrading from?
Which version of CLM or Insight are you upgrading to?
Which database vendor are you using for the data warehouse?
Which operating system is hosting the data warehouse database?
Result of executing the following SQL SELECT statement against the data warehouse:
SELECT * FROM CONFIG.SYSCONFIG_INFO

<CLM_Install>/server/repotools-jts_upgradeWarehouse.log (back up the database and re-run the repotools command if needed)
NOTE: Starting in CLM 4.0, RRDI 2.0 and Insight 1.1.1, you can customize the schema name. If you customized the schema name in your environment, you need to modify the SELECT * FROM CONFIG.SYSCONFIG_INFO query to use your customized schema's name.




DATA WAREHOUSE CREATION
Which database vendor are you planning to use for your data warehouse?
Which operating system will host the data warehouse database?
If using the RRDI Setup Wizard to create the Data Warehouse, Run the setup wizard with TRACE logging enabled
If the database objects were created using repotools or jts/setup, provide the jts.log and a copy of the repotools-jts_createWarehouse.log found in the jts/server directory




MIGRATING INSIGHT CUSTOMIZATIONS (XDC, Data Warehouse, FM Model)
Data Warehouse Customization

Obtain a copy of the following logs and configuration files:
    · <RRDI_DevTool_Install>\migration\<version>\dw\migrateDW.properties
    · <RRDI_DevTool_Install>\migration\<version>\dw\migrateDW.properties
    · <RRDI_DevTool_Install>\migration\<version>\dw\migrateDW.log

Command executed to run the migration
ETL Customization

Obtain a copy of the following logs and configuration files:
    · <RRDI_DevTool_Install>\migration\<version>\etl\migrateETL.log

A copy of the ETL catalog being migrated

Command executed to run the migration
Reporting Data Model (FM Model)

<RRDI_DevTool_Install>\migration\<version>\fm\ (entire folder)

A copy of the FM model being migrated

Command executed to run the migration
XML Data Configuration

A copy of the XML Data Configuration file being migrated

<RRDI_DevTool_Install>\migration\<version>\xdc\migrateXDC.log

Command executed to run the migration





REPORTING DATA MODELS
Datea nd Time of the problem
Which data model do you use?
Screenshot of the problem
Obtain a copy of the following log file:
      <RRDI_Install>\cognos\logs\cogserver.log





DATA SERVICES
Which version of Data Services are you using?

Which version of WebSphere is Data Services deployed on?

Which Data Services adapter(s) are you using?

A copy of the WebSphere logs for the Data Services profile (for example, C:\IBM\WebSphere\ AppServer\profiles\RationalDS\logs)

Corresponding ETL logs (if ETL related)

Copy of the web.xml from the Data Services WebSphere profile (e.g. C:\IBM\WebSphere\ AppServer\profiles\RationalDS\config\cells\<cell_name>\applications\DataServices.ear\deployments\DataServices\DataServices.war\WEB-INF\web.xml)

RequisitePro


Version of RequisitePro

Copy of the ReqWeb catalog.txt

Copy of the ReqWeb WebSphere logs

Copy of the ReqPro XDC file
ClearCase


Version of ClearCase

Copy of the ClearCase XDC file

Is cleartool.exe in the system PATH?
ClearQuest


Version of ClearQuest

ClearQuest Installation Path
TestManager


Version of TestManager

Test Manager Installation Path

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Product Synonym

Rational DOORS Next Generation;Rational Team Concert;Rational Quality Manager

Document Information

Modified date:
16 June 2018

UID

swg21645071