IBM Support

Not able to use item upload feature from SBC

Troubleshooting


Problem

Feature 'master data upload' for item upload from SBC. CSV file was downloaded as template and following properties are set in customer override file :-. yfs.sc.file.upload.dir=D:/folders/sterling92/Foundation/Temp yfs.sc.file.upload.maxfilesize=10MB yfs.sc.file.upload.maxfilesize.yfs_item=10MB yfs.sc.file.upload.allowedfiletypes=*.txt,*.pdf,*.doc,*.csv yfs.sc.file.upload.type=ONSUBMIT On click of 'Submit' button, message is displayed as 'File data submitted successfully' Upload status is shown as In Queue . On line documentation doesn't mention how to go further with item upload. Is there a need to setup agent server which would receive data from the queue?

Symptom

Upload status shows as "In Queue" only on SBC status screen

Cause

Need to run Agents for data processing

Diagnosing The Problem


 

Resolving The Problem

Need to configure the following Agents for data processing and run them:-
1.Master upload Scheduler
2.Master upload Runner,
3.Master upload Summarizer

Agent configuration should resolve the the problem

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management System Software"},"ARM Category":[{"code":"a8m0z000000cxzrAAA","label":"Inventory"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;9.0.0;9.1.0;9.2.0;9.2.1;9.3.0;9.4.0;9.5.0"}]

Document Information

Modified date:
20 November 2025

UID

swg21626599