IBM Support

QRadar: Column headers are not present in 'Export to CSV' option

Question & Answer


Question

How do you get column headers included in your 'Export to CSV' output?

Cause

By default the Include Header in CSV Export setting is No.

Answer

By default, CSV column headers are disabled. You can enable the headers using this procedure.
  1. Click the Admin tab > System Settings icon.
  2. In the navigation menu, click Data Export Settings.
  3. Change the Include Header in CSV Export field to Yes.
    image-20230912155736-1
  4. Click Save.
  5. Click the Admin tab.
  6. Click Deploy Changes.

    Results
    Wait for the deployment to complete. Exports from the Log Activity or Network Activity tabs include the header in the CSV output. To test an export, create a one-minute or use a limit in the Log Activity tab and export your CSV file to test that the headers are included. For example, to easily create a search for export a small number of events, you can use an Advanced search, such as select * from events LIMIT 20. If the System Setting is correct, but you do not see CSV headers in your export, contact QRadar Support for assistance. 

 

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwtEAAQ","label":"Log Activity"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"},{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKMKU","label":"IBM QRadar on Cloud"},"ARM Category":[{"code":"a8m0z000000cwtEAAQ","label":"Log Activity"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Product Synonym

IBM QRadar

Document Information

Modified date:
12 September 2023

UID

swg21622663