Troubleshooting
Problem
In IBM Installation Manager, a blank browser shows when you view a log file, a list of the installed packages, or an installation history file with a Chrome browser.
Cause
The Chrome browser does not show .xml files from the file system that have associated .xsl style sheet.
This issue has been reported:
Issue 47416: Allow a directory tree to be treated as a single origin
Issue 39616: XML with XSL not shown under file:// scheme
To reproduce the issue:
- Click File > View Log. Select a log file and click the open log file icon.
- Click File > Installation History. Select an installation entry and click the open installation history file icon.
- On Windows, click Start > [All] Programs > IBM Installation Manager > View Installed Packages.
The installed.xml file is used when you click View Installed Packages. The following lines from this file show that a .xsl style sheet is used:
<?xml version='1.0' encoding='UTF-8'?>
<?installInfo version='0.0.3'?>
<?xml-stylesheet type='text/xsl' href='installed.xsl'?>
Resolving The Problem
To work around this issue:
- Use a different browser like Mozilla Firefox or Microsoft Internet Explorer.
- NOTE: This solution might be a security vulnerability for Chrome and is not recommended by IBM. For more information, see Issue 4197: Further restrict access of file URL.
Use the --allow-file-access-from-files command line option to start the Chrome browser.
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Document Information
Modified date:
25 October 2021
UID
swg21609349