Question & Answer
Question
In some scenarios, users of WebSphere Cast Iron NetSuite connector cannot view some of the custom fields of a record.
Cause
As per the existing NetSuite API design, it does not support dynamic discovery of custom fields for a record.
Answer
Gather the following information from the NetSuite Administrator:
The information needed for each record is:
- The types of custom fields it should have (ex. Entity Fields, Item Fields, Transaction Column Fields etc.)
- The type of record it applies to (ex. Account)
For example, a mapping that says record "Purchase Order" should have Transaction Body Fields and should have custom fields to which it applies as "Purchase". Thus WebSphere Cast Iron can make API calls internally to show proper custom fields for "Purchase Order"; however, due to the nature of the Netsuite API design, WebSphere Cast Iron may not be able to display some custom fields even if the above information about these custom fields is supplied.
Contact IBM Support if you need additional information.
[{"Product":{"code":"SSGR73","label":"IBM Cast Iron Cloud Integration"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Connectors","Platform":[{"code":"PF009","label":"Firmware"}],"Version":"6.4.0.1;6.3.0.2;6.3.0.1;6.3;6.1.0.9;6.1.0.6;6.1.0.3;6.1.0.2;6.1.0.15;6.1.0.1;6.1","Edition":"Virtual;Physical","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21606208