Troubleshooting
Problem
GJS0054E, AWSJSY404E, AWSDEB009E, GJS2031E, and "connection with r3batch system failed" errors are received as you attempt to create new job definitions for the R3 instance.
Symptom
Pop up windows with the above errors are presented when you attempt to create jobs in Tivoli Workload Scheduler (TWS) for Applications for SAP using either the Job Scheduling Console (JSC) or the Tivoli Dynamic Workload Console (TDWC).
See the various errors in the attached document in the "Related information" section below.
Cause
There are three main possible causes for these errors:
CAUSE #1: The information in either the r3batch.opts file or the <XAGENTNAME>_r3batch.opts is incorrect or corrupted. Here are some things to check:
- The r3host name is mandatory and must be the name of the SAP message server when using logon groups, or the host name of the application server in all other cases. If this server can be reached through one or more SAP gateways, use a string in the format /H/gateway/H/ for each of them
- The LJuser and IFuser in r3batch.opts must be correct
- The r3user is mandatory...make sure it is correct. It is the name of the SAP user with which the access method connects to the SAP system. It must have the appropriate privileges for running background jobs. It is sometimes also called the Maestro User ID.
- The r3password must be encrypted using enigma. It is the password for the r3user. Ensure that you enter the same password when creating this user in the SAP system. It can be a maximum of eight characters and is stored in encrypted format. The value is case sensitive.
- You did not copy the r3batch.opts file or the <XAGENTNAME>_r3batch.opts file in binary mode from one workstation to another (for example, during an upgrade or move of the extended agent to another system). It is possible that there are hidden control M (^M or CTRL-M) characters at the end of each line in the file(s). Also, check that permissions and ownership are correct. Set file permissions to 755 and ensure the twsuser owns the file(s).
NOTE: All of the mandatory options for the r3batch.opts and <XAGENTNAME>_r3batch.opts are described in the TWS for Applications User Guide in this section:
http://publib.boulder.ibm.com/infocenter/tivihelp/v3r1/topic/com.ibm.tivoli.itwsfa.doc/awsaumst121.htm?path=84_3_7_2_0_1#wq239
CAUSE #2: The proper transport files have not been added to the SAP R/3 server and imported into the SAP R/3 database. See this link: http://publib.boulder.ibm.com/infocenter/tivihelp/v3r1/topic/com.ibm.tivoli.itwsfa.doc/awsaumst113.htm?path=84_3_7_1_3#copycorr
CAUSE #3: The FTA hosting the XAGENT cannot communicate with the SAP R/3 application server. Check the network connections between the SAP R/3 server and the FTA hosting the XAGENT. Also, ensure there are no issues on the SAP server.
Diagnosing The Problem
If you are not able to resolve the issue after checking the above causes, complete the following to send to TWS Support:
ANSWER:
- TWS for Apps Patch Level:
- Output of "r3batch -v" run from <twshome>/methods directory:
- Version of SAP Application:
- Version of SAP Kernel:
SEND:
- Rename, XA host <twshome>/methods/dev_rfc and <twshome>/methods/traces/trace-r3batch.log, then run:
./r3batch -t PL -c (xagentname) -l \* -j \* -- "-debug -trace" > <filename>
- Send new dev_rfc and trace-r3batch.log files, and <filename>
- Send r3options file
- Send r3batch.opts file
- <XAGENTNAME>_r3batch.opts file
- Gather and send data collected by the tws_inst_pull_info script. Run this on the master as root and also the hosting FTA (if it is not the master). The script is available in the following Technote:
http://www-01.ibm.com/support/docview.wss?uid=swg21295038
COMPLETE:
- Verify the joblaunch user is a valid, sufficiently authorized SAP user.
- Verify all SAP Notes are installed as required - as stated in the TWS for Applications User's Guide - Software Requirements: http://publib.boulder.ibm.com/infocenter/tivihelp/v3r1/topic/com.ibm.tivoli.itwsfa.doc/awsaumst100.htm?path=84_3_7_0_0#sapswreq
Resolving The Problem
Ensure that all the points mentioned in the "CAUSE" section above have been verified and addressed.
In most cases, your Basis Administrator will need to be consulted to provide correct connection information and to assist with adding transport files, ABAP/4 function modules, r3sid, etc.
Also, consult with your network administrator to ensure proper network communication between the Fault Tolerant Agent (FTA) hosting the SAP extended agent and the SAP application server.
If you are still unable to resolve the issue, gather all the information from the "Diagnosing the Problem" section above, open a PMR, and consult with TWS support for assistance.
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Document Information
Modified date:
17 June 2018
UID
swg21577981