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Import and Export Ontology buttons disabled with Content Analyzer

Troubleshooting


Problem

After a user attempts to import an ontology, the import never completes and the Import Ontology and Export Ontology buttons remain disabled.

Cause

During import of an ontology, the Import Ontology and Export Ontology buttons are disabled to prevent any access until the ontology import is complete.  If an unhandled exception occurs during the import, such as when encountering corrupted data in the JSON import file, the buttons do not get reenabled.

Resolving The Problem

To re-enable the ontology buttons, the partial import needs to be deleted from the tenant database.  Run the following, substituting the values noted in angle brackets.
  1. On the database server, log in to the tenant database.
        db2 connect to <tenantdb> user <tenantdbuser> using <password>
  2. Delete the failed import records.
        db2 delete from <ontologyname>.import_ontology;
  3. On the Content Analyzer system, restart the backend pods.
        oc delete pods <space separated list of backend pod names>
  4. Log in to Content Analyzer again and the buttons are enabled.

Document Location

Worldwide

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Product Synonym

ACA

Document Information

Modified date:
06 March 2020

UID

ibm11847745