Troubleshooting
Problem
After a user attempts to import an ontology, the import never completes and the Import Ontology and Export Ontology buttons remain disabled.
Cause
During import of an ontology, the Import Ontology and Export Ontology buttons are disabled to prevent any access until the ontology import is complete. If an unhandled exception occurs during the import, such as when encountering corrupted data in the JSON import file, the buttons do not get reenabled.
Resolving The Problem
To re-enable the ontology buttons, the partial import needs to be deleted from the tenant database. Run the following, substituting the values noted in angle brackets.
- On the database server, log in to the tenant database.
db2 connect to <tenantdb> user <tenantdbuser> using <password> - Delete the failed import records.
db2 delete from <ontologyname>.import_ontology; - On the Content Analyzer system, restart the backend pods.
oc delete pods <space separated list of backend pod names> - Log in to Content Analyzer again and the buttons are enabled.
Document Location
Worldwide
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSUM7G","label":"IBM Business Automation Content Analyzer on Cloud"},"Component":"","Platform":[{"code":"PF040","label":"RedHat OpenShift"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Product Synonym
ACA
Was this topic helpful?
Document Information
Modified date:
06 March 2020
UID
ibm11847745