IBM Support

SSL Connect error 2 during Client SSL connection (SCI52946)

Troubleshooting


Problem

SSL Connect error 2 during Client SSL connection (SCI52946)

Symptom

SSL connect error 2
*OPTIONS has SSL_DEFAULT_CLIENT_AUTH_POLICY=DISALLOWED
*REMOTES does not have SSL_CLIENT_AUTH_POLICY=REQUIRED

Cause

ODF parameter conflict - SSL is not allowed

Resolving The Problem

Add SSL_CLIENT_AUTH_POLICY=REQUIRED to the REMOTES definition or change the default to SSL_DEFAULT_CLIENT_AUTH_POLICY=OPTIONAL

[{"Product":{"code":"SSG266","label":"IBM Sterling Connect:Enterprise for z\/OS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Historical Number

PRI33884

Product Synonym

[<p><b>]Fact[</b><p>];Connect:Enterprise OS/390, Release 1.2.00 [<br/>] CONNECT:Enterprise RDX for
OS/390, Release 1.1.00 [<br/>] SCI52946

Document Information

Modified date:
17 December 2019

UID

swg21525225