Troubleshooting
Problem
Error on change status when changing to completed or closed while processing tickets which are associated to an asset.
Symptom
Receive error:
CTGRD00010 - Could not change Change 180874 status to COMP. null
or
BMXAA0032E - Cannot chnage the status to the same status

Cause
NullPointerException occurs when the system is trying to look for an object that is not there.
Diagnosing The Problem
Excerpt from SystemErr.log
java.lang.NullPointerException
[7/3/11 16:37:10:105 EDT] 000000b7 SystemErr R at
psdi.app.asset.Asset.isRotating(Asset.java:1735)
[7/3/11 16:37:10:105 EDT] 000000b7 SystemErr R at
psdi.app.workorder.WO.canChargeStore(WO.java:3372)
[7/3/11 16:37:10:105 EDT] 000000b7 SystemErr R at
psdi.app.workorder.WO.isAssetChargeStore(WO.java:3336)
[7/3/11 16:37:10:105 EDT] 000000b7 SystemErr R at
psdi.app.workorder.WO.applyAssetLoc(WO.java:1616)
[7/3/11 16:37:10:105 EDT] 000000b7 SystemErr R at
psdi.app.workorder.FldWOAssetnum.coordinateAssetLocChange(FldWOAssetnum.
java:506)
[7/3/11 16:37:10:105 EDT] 000000b7 SystemErr R at
psdi.app.workorder.FldWOAssetnum.action(FldWOAssetnum.java:196)
Resolving The Problem
Create a SQL log by following the online doc below
https://www-304.ibm.com/support/docview.wss?q1=1385917&rs=3214&uid=swg21385917&context=SSLKT6&cs=utf-8&lang=en&loc=en_US
Review last SQL statement before the error:
select * from item where itemnum = 'C400' and itemsetid = 'SET2'
Go to Item Master application and search for item C400.
If it's not there, create the item in the Item Master application.
Go to the Change application and change status to COMPLETE again. There should be no error in changing status this time.
Related Information
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Document Information
Modified date:
19 August 2022
UID
swg21506721