IBM Support

Why might my images be blurry when viewed in Content Manager for iSeries Client Application Version 5 Release 1?

Question & Answer


Question

I just installed Fix Pack 19 of the Content Manager for iSeries Client Application Version 5 Release 1 and some of my images are blurry. Why might this be?  

Cause

It's possible your viewer engines are in the wrong order and that switching the order they are loaded will allow improved viewing of your images. The best viewing order depends on the type of images you display (e.g., TIFF or MODCA). TIFF images are best handled by the Pixel Translations Engine while MODCA images are best handled by the IBM Engine.

Answer

If the blurry image you are viewing is MODCA rather than TIFF, try executing the following steps:
1. Use Windows Explorer to launch the FRNWVIEW.EXE from the Content Manager Client for Windows installation directory (e.g, C:\Program Files\IBM\CM for iSeries). This will launch the IBM Content Manager Viewer.
2. Click on Options, File Handlers. The loaded file handlers will be listed in the right pane, "Loaded File Handlers".
3. If the Pixel Translations Engine is listed before the IBM Engine, click on it and then the "Remove" button, This will remove it from the list on the right, "Loaded File Handlers", and move it to the list in the left pane, "Available File Handlers", as shown below:

4. Click on the removed engine in the left pane, "Available File Handlers", and then the "Add" button. This will add it to the bottom of the "Loaded File Handlers" list in the right pane.
5. Make sure the IBM Engine is listed first, then the other two engines, Pixel Translations and MasterSoft Engine, in second and third place, respectively. You might need to do multiple removes and adds in order to make the engines appear in the correct order in the "Loaded File Handlers" list.

6. Click on OK to save the changes made.
7. Close the IBM Content Manager Viewer. Launch the Content Manager Client for Windows, connect to the iSeries, and try displaying the image again.

Adjustments may be made to this file as necessary. Changes are recorded in the FRNWVIEW.INI file stored in the C:\WINDOWS directory.  


If the image you are viewing that is blurry is TIFF, try setting the Pixel Translations Engine first, the IBM Engine second and the MasterSoft Engine third. In addition, there are two environment variables that can be used to help with rendering TIFF images:
FIWT_USEPIXEL_SCALETOGRAY=TRUE and
FIWT_USEPIXEL_ RENDERTIFF=TRUE.

It is recommended that you also install any fixes that have been created after Fix Pack 19; these are available from and documented on our web site: ftp://ftp.software.ibm.com/as400/products/contentmanager/v530/client/. All IOxxxxx fixes should be loaded from low number to high number or install the IO_RollUp.zip, which contains a consolidation of all the fixes for the product.

If these steps do not fix the problem, contact IBM software support for further assistance.


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Document Information

Modified date:
17 June 2018

UID

swg21472692