IBM Support

Received SWIFT network ABORT codes SA100 and RP052 when logging in from IBM WBIFN

Troubleshooting


Problem

Receiving SWIFT ABORT code of SA100 and diagnostic code of RP052 in IBM WebSphere Business Integration for Financial Networks (WBIFN) for z/OS.

Symptom

DNFF4069I 8/23/10 11:40:49 PM ATBOU DNF_FSM LT 'ATBRCA60A': SYS ABORT  received, ABORT code='SA100', ABORT diagnostic code='RP052'.

Cause

According to the SWIFT User handbook, the RP052 means:

RP : protocol error
052: Reception of a login from an LT for which the system already has an APC created by a login transmitted over a different LTC on the same RP. The existing APC is aborted with this code and the new APC established.



This means, that the LT is logged into the SWIFT network, when a second login request is received from another FIN CBT.
The active session gets aborted by SWIFT with the above abort codes.


In this case, another group using another FIN CBT was also logging into SWIFT using the same LT. After WBIFN logged the LT into SWIFT the other group issued a new login request for the same LT and this caused the LT session abort in WBIFN with the above error indication.

Resolving The Problem

Ensure that the LT is only being used in one system at a time and not being used in multiple systems at the same time.

[{"Product":{"code":"SS433P","label":"WebSphere Business Integration for Financial Networks"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"3.1;3.1.1","Edition":"","Line of Business":{"code":"","label":""}}]

Product Synonym

WebSphere Business Integration for Financial Networks for z/OS

Document Information

Modified date:
16 June 2018

UID

swg21444964