Troubleshooting
Problem
The amount of space occupied by active log files (as viewed at the operating system level) is different than the amount of used active log space reported by the QUERY LOG command.
Cause
Working as designed
Diagnosing The Problem
Run the QUERY OPTION command to verify the size of the active log. For example:
tsm: MYSERVER>query option activelogsize
Server Option Option Setting
----------------- --------------------
ActiveLogSize 5,120
The output shows that the active log size is set to 5120 MB.
The operating system shows active log files for a total size of 5120 MB. For example:
F:\tsm_server1\log>dir
Volume in drive F is TSM_LOG
Volume Serial Number is 90FE-A4FA
Directory of F:\tsm_server1\log
08/12/2010 07:07 PM <DIR> .
08/12/2010 07:07 PM <DIR> ..
08/10/2010 04:42 AM 536,879,104 S0000147.LOG
08/10/2010 05:34 AM 536,879,104 S0000148.LOG
08/12/2010 04:03 PM 115,273,728 S0000149.LOG
...and so on
A Spectrum Protect Server database backup (BACKUP DB) is run but the active log files are not deleted from the operating system. The active log continues to use the same amount of space.
Resolving The Problem
This is normal. Allocated space in the active log is reused by the Spectrum Protect server instance. Where a database backup does delete old "archive" log files, it does not delete the "active" log files from the operating system. Those active log files are reused as needed. Use the QUERY LOG FORMAT=DETAILED command to verify the current used space in the active log. For example:
tsm: MYSERVER>query log f=d
Total Space(MB): 5,120
Used Space(MB): 147.88
Free Space(MB): 4,952.12
Active Log Directory: F:\tsm_server1\log
Mirror Log Directory:
Archive Failover Log Directory:
Archive Log Directory: G:\tsm_server1\archlog
The above output shows that the active log size is 5120 MB but only 147.88 MB is actually used in the allocated space.
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Document Information
Modified date:
17 June 2018
UID
swg21444616