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System state backup fails with ANS5250E error

Troubleshooting


Problem

A system state backup is initiated from the Tivoli Storage Manager client. The backup fails with the ANS5250E error and a return code of 162.

Symptom

The dsmerror.log file of the client shows the following errors:

<timestamp> ANS5250E An unexpected error was encountered.
TSM function name : PrivObjEnumBack
TSM function : fioGetAttrib failed for file 'C:\adsm.sys\vss_staging\XXX\YYY\DATE\COM+ REGDBWriter.xml'
TSM return code : 162
TSM file : incrdrv.cpp (13919)
<timestamp> ANS1999E Incremental processing of 'XXXX\SystemState\NULL\Systemtate\SystemState' stopped.

Cause

Microsoft group policy hides the C: drive from the view.

Diagnosing The Problem

Add the following option to the client options file :

PRESC "reg query HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer > regqry.out"

The above command will query the registry prior to running the schedule backup. Stop and restart the client scheduler for the option to take effect. Run a backup to recreate the failure and examine the regqry.out file. For example :

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDrives REG_DWORD 0xf

The NoDrives key value is set to 0xf, which causes the C: drive to be hidden from backup.

Resolving The Problem

This error is caused by a group policy hiding the C: drive from the view. To successfully complete a system state backup operation, do not hide the C: drive. For more information on the group policy, refer to the following Microsoft article:
http://technet.microsoft.com/en-us/library/cc938267.aspx

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21443261