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ATTRIBUTE GROUP RETURNED NULL for AGENTLOG object

Troubleshooting


Problem

The Availability workspace under the Tivoli Storage Manager section in the Tivoli Enterprise Portal shows an INACTIVE status for the AGENTLOG object.

Cause

Working as designed

Diagnosing The Problem

Log on to the Tivoli Enterprise Portal. Expand the appropriate system being monitored. Expand the Tivoli Storage Manager section. Select the Availability workspace. The Agent Status window on the right reports an INACTIVE status for the AGENTLOG. For example :



Also, selecting the AGENTLOG workspace will report "This view has not been defined".

Resolving The Problem


It is normal for an object to show a status of INACTIVE with Error Code of "ATTRIBUTE GROUP RETURNED NULL" when there is no data available for the specific object.

In this case, it indicates that there is no data available for the AGENTLOG. The AGENTLOG is used for logging specific events of the Reporting Agent. Currently, the following conditions are logged:

  1. Client_Missed_Files returns too much data from tsm server (more than 50000 by default)
  2. Node_Activity returns too much data from tsm server (more than 50000 by default)
If neither of the above conditions are met, no data is logged for the Reporting Agent. Because no data is logged, and it is normal for the AGENTLOG status to be inactive.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
23 June 2018

UID

swg21407117