IBM Support

Database connection failure when installing the Translator server on IBM i

Troubleshooting


Problem

The database connection fails because WebSphere Application Server typically runs under a user profile that does not have a password. A password is required to connect to a database. The resolution is to run WebSphere under a user profile that has a password.

Cause

This failure is because the QEJBSVR profile does not have a password associated with it, and as a result WebSphere cannot connect to a database because the database connection requires a user name and password.

Resolving The Problem

To resolve the problem, change the user profile that WebSphere Application Server runs under. The new user profile must have the same authority as the QEJBSVR and must also have a password associated with it. It is this user name and password that you enter into the database connection field when installing the Webform Server Translator.

To change the user profile, see the Running application servers under specific user profiles topic on the Websphere Application Server (i5/OS) information center.

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Document Information

Modified date:
23 June 2018

UID

swg21406353