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How do I avoid "The resources that are required for straight-through processing are not reachable." error being displayed when trying to access Case client from an external IBM Content Navigator configuration

Troubleshooting


Problem

In an IBM Business Automation Workflow environment that has Case features enabled, if the environment is configured with an external IBM Content Navigator, then an error might be displayed to the user.  Clicking the 'link' that is provided in the dialog and accepting a certificate warning allows the error to go away.
The error is:
The resources that are required for straight-through processing are not reachable. To fix the problem, click link. If you are prompted to add an exception to your browser for an invalid server certificate, add one. Otherwise, check that the server is running. Then return to Desktop page and click Ok to reload the Desktop
It looks like the following:
image-20200103142739-1

Cause

One possible cause to the error is due to SSL certification configuration. Access to IBM Business Automation Workflow with or without an external IBM Content Navigator server is done through SSL. If the application servers are configured with a self-signed certificate, and not a certificate signed by a certificate authority, then the browser displays a warning about the certificate used for the SSL connection. In order to proceed from the warning, the browser requires the user to interactively accept it and proceed to trust the connection.  These interactive manual steps are what causes the 'Straight-through' processing error.
For a certificate-related cause, the link provided in the error dialog allows the user to interactively trust the certificate that is used by the IBM Business Automation Workflow deployment environment application server. Once the warnings are interactively accepted, an SSL connection to both the external IBM Content Navigator server and the IBM Business Automation Workflow environment is established.
Aside from self-signed certificate configuration issues, the error is also displayed when IBM Business Automation Workflow it not configured correctly with an external IBM Content Navigator.

Environment

IBM Business Automation Workflow v19.0.0.1 or later with external IBM Content Navigator configured

Resolving The Problem

Depending on the symptom you are experiencing, there are different paths to the resolution.
  1. Confirm that the issue is specific to self-signed certificates
    1. If the issue is specific to self-signed certificates, then the following conditions might hold true.
      When you access IBM Content Navigator URL to case client, you are presented a warning from the browser regarding the self-signed certificate.  An example of a certificate warning is:
      Your connection is not private
      Attackers might be trying to steal your information from enounce1.fyre.ibm.com (for example, passwords, messages, or credit cards). Learn more
      NET::ERR_CERT_COMMON_NAME_INVALID

      or

      net::ERR_CERT_AUTHORITY_INVALID
       
      Accepting the warning takes you to the IBM Content Navigator login pane
    2. When you arrive on the IBM Content Navigator login pane, you are presented with the 'The resources that are required for straight-through processing are not reachable.' window.  Clicking the 'link' in the window takes you to the URL for the IBM Business Automation Workflow server, at which point, you are presented with another warning about the ERR_CERT_COMMON_NAME or ERR_CERT_AUTHORITY_INVALID.  Accepting the 2nd warning takes you back to the 'straight-through processing' window.  Now click 'Ok' in the window, which refreshes the browser window as a whole.  You can now log in, and use the case client application.
    For self-signed certificate issues, you can resolve the issue by taking the following actions.
    1. Using a signed certificate from a valid certificate authority.  The preferred approach for certificate warning issues.
      1. DigiCert
      2. VeriSign
      3. Thawte
    2. Importing a self-signed certificate. Note: You need perform the same import on each client workstation accessing the case client application.
      You need to import the certificates from both the IBM Business Automation Workflow deployment environment and the certificate from the external IBM Content Navigator.
      1. Self-signed certificate from IBM Business Automation Workflow deployment environment
      2. Self-signed certificate from external IBM Content Navigator
      For Microsoft™ Edge:
      https://www.toptip.ca/2018/12/allow-microsoft-edge-to-visit-self-sign.html
  2. If your situation is different than the certificate issue discussed in bullet 1, and you run into other issues listed in the following bullets, then you did not configure your environment correctly.
    1. You get redirected to the IBM Business Automation Workflow server after you click the link in the 'Straight-through processing' window, but you do not get a certificate warning. Instead, you receive an error or page not found.
    2. After you accept the certificate warning from the IBM Business Automation Workflow server, and click the 'Ok' in the 'Straight-through processing' window, you continue to see the 'Straight-through processing' window.
    For configuration issues, verify that you performed all of the tasks related to configuring an external IBM Content Navigator (Configuring IBM Business Automation Workflow with an external IBM Content Navigator). Follow all of the steps and double check that you went through all of the steps.  Specifically, check the following items.
    1. Configuring single sign-on - Configuring single sign-on with LTPA for an external IBM Business Automation Navigator.  Documented in step 2.
      1. If single sign-on is configured correctly, then as the end of step 3 states: "You are successful in establishing single sign-on (SSO) between the two systems when you can log in to one administrative console and then access the other administrative console without having to log in again. Log in to the WebSphere Application Server administrative console where you exported the LTPA key. In your browser's address bar, enter the URL for the WebSphere Application Server administrative console where you imported the LTPA key. If the administrative console opens without requiring you to log in, you successfully set up SSO."
    2. Configure network share directory correctly. Documented in step 4.  If you are changing the network share location, you can use the following guide: Changing the network shared directory
    3. Run the command to configure external IBM Content Navigator - setExternalNavigator command.  This command is listed in step 6.  After setExternalNavigator completes successfully, follow step 7 - 10.  Especially pay attention to run step 9, and rerun all of the tasks in the Case configuration tool, making sure to run 'Register the Case Widgets Package'.
    4. Run the configuration tasks for Case configuration.  Documented in step 9.
      1. development - Running the development environment case configuration tasks
      2. production - Running the production environment configuration tasks

Document Location

Worldwide

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Document Information

Modified date:
10 August 2021

UID

ibm11167952