IBM Support

Migrate services from 1.3 & 1.5 to 2.6 without client changes

News


Abstract

Migrate services from 1.3 & 1.5 to 2.6 without client changes

Content

 

What is it?

You now have the ability to move web services that are deployed on integrated web services (IWS) servers with a version of 1.3 and 1.5 to version 2.6 servers without having to resend the WSDL file to all your client applications.  Previously, you had the ability to move services, but you then had to send the WSDL to all clients of the web service.

The restoreWebServices.sh can now generate logically equivalent WSDL files when a 1.3/1.5 service is restored to a version 2.6 server. If you are migrating from version 1.3 of the IWS server, ensure that you specify "version13" on the -migrationOptions parameter of the command.

NOTE: You will still need to do APACHE HTTP server URL remapping to map the endpoint clients use.  See the Administration and Programming Guide for more details.

Why use it?

There are several important reasons:

  • Limits disruption to your clients that are using the web service.
  • Must be used in IBM i 7.3 since 1.3/1.5 servers are not supported in i 7.3.
  • To get on the strategic IWS server version and supported JVM with minimal disruption.

Availability

The support is enabled in the following PTFs:

SI68894 V7R1M0

SI68864 V7R2M0
SI67429 V7R2M0

SI68865 V7R3M0
SI67430 V7R3M0

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"HW1A1","label":"IBM Power Systems"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
30 December 2019

UID

ibm11138636