Question & Answer
Question
In the SystemOut.log, continuous error as below:
[15/11/19 17:00:53:600 SGT] 000000c7 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:694 SGT] 000000c7 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:694 SGT] 000000cb WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:694 SGT] 000000c6 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:710 SGT] 000000c7 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:600 SGT] 000000c7 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:694 SGT] 000000c7 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:694 SGT] 000000cb WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:694 SGT] 000000c6 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
[15/11/19 17:00:53:710 SGT] 000000c7 WebCollaborat A SECJ0056E: Authentication failed for reason No Client Certificate Available
Cause
This err msg means that your application required "Client cert authentication" however client (e.g. IE browser) did not provide such certificate:
com.ibm.ws.security.web.WebCollaborator : SECJ0056E: Authentication failed for reason No Client Certificate Available
com.ibm.ws.security.web.WebCollaborator : SECJ0056E: Authentication failed for reason No Client Certificate Available
Answer
Enable "Default to basic authentication when certificate authentication for the HTTPS client fails" may solve the issue.
Steps:
Go to WebSphere Admin Console >Global security > Web security - General settings
Enable "Default to basic authentication when certificate authentication for the HTTPS client fails" (default: disabled).
Go to WebSphere Admin Console >Global security > Web security - General settings
Enable "Default to basic authentication when certificate authentication for the HTTPS client fails" (default: disabled).
More explanation can be found here:
https://www.ibm.com/support/knowledgecenter/SSAW57_8.5.5/com.ibm.websphere.nd.multiplatform.doc/ae/usec_webauth.html
https://www.ibm.com/support/knowledgecenter/SSAW57_8.5.5/com.ibm.websphere.nd.multiplatform.doc/ae/usec_webauth.html
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Document Information
Modified date:
12 December 2019
UID
ibm11134927