IBM Support

QRadar:アップグレード後にすべてのログソースがイベントを収集していない

Troubleshooting


Problem

ECS サービスは、アップグレード後にポート 514 またはその他の主要ポートで待ち受け状態にならない場合があります。

Symptom

/var/log/qradar.log に次のエラーメッセージが表示される場合があります。

Error attempting to load
DemoQRADAR.example.NET:ecs-ec/EC/Q1Labs_SyslogRedirect Error :
java.lang.NoClassDefFoundError:
com.q1labs.semsources.sources.utils.listener.tcp.ITCPSyslogListenerSubscriber

Cause

これは、自動更新ページのオプション「サービスの自動再起動」が無効になっている場合に発生します。 設計上、このオプションが無効になっている場合、プロトコルはインストールされません。

Resolving The Problem

この問題を解決するには、以下の手順を使用します。

  1. QRadarユーザーインターフェースにログインします。
  2. 以下の管理設定を開きます:
    1. IBM Security QRadar V7.3.1で、ナビゲーション・メニューをクリックします。 , 次に「管理」をクリックして、「管理」タブを開きます。
    2. IBM Security QRadar V7.3.0 以前で、「管理」タブをクリックします。
  3. 自動更新」のアイコンをクリックします。
  4. 新規更新の取得」 > 「すべての更新のインストール
  5. これが「管理」ページから完了したら、「拡張」 > 「 Web サーバーの再始動」をクリックします。


この問題が再発しないようにするには、次のようにします。

  1. 「管理」タブで「自動更新」アイコン > 「設定の変更」をクリックします
  2. ボックスをチェックして「サービスの自動再始動」 > 「保存」をクリックします。
  3. 変更をデプロイする必要はありません。

結果: ログ・ソースがイベントを収集しています。

QRadar に関する情報は以下のリンクからも確認できますのでご参照ください。


[{"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Upgrade","Platform":[{"code":"PF016","label":"Linux"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
29 November 2019

UID

ibm11114755