IBM Support

Enabling Issues & Transfers application in Maximo 7.5 fails

Technical Blog Post


Abstract

Enabling Issues & Transfers application in Maximo 7.5 fails

Body

You just started up a new 7.5.0.3 environment, and see the Issues and Transfers application in the Application Designer and in the Security Groups application, but you don't see it in the Go To menu for 
the Inventory module.  Can we get the steps for restoring it?  (You noticed that the Issues and Transfers application is missing from the Go To menu.)

 

 

Run the following queries :

SELECT * FROM MAXMENU WHERE MODULEAPP = 'INVENTOR'   AND ELEMENTTYPE = 'APP' AND KEYVALUE = 'INVISSUE'

SELECT * FROM MAXAPPS WHERE APP = 'INVISSUE'

 

The problem is likely caused by missing data in MAXMENU table.  

 

To fix your issue,  you need to insert data. 
 
Run below query. 

SELECT MAX(POSITION) FROM MAXMENU WHERE MODULEAPP = 'INVENTOR'   AND ELEMENTTYPE = 'APP' 
 
If  X value returns, Please run below query. 

 

Insert into MAXMENU (MENUTYPE, MODULEAPP, POSITION, SUBPOSITION, ELEMENTTYPE, KEYVALUE, 
VISIBLE, IMAGE, MAXMENUID, ROWSTAMP)  
values ('MODULE', 'INVENTOR',10610, 0, 'APP', 'INVISSUE', 1,'appimg_invissue.gif', MAXMENUSEQ.NEXTVAL, '1671357'); 

For example, if X is 10600 , 
 
Insert into MAXMENU (MENUTYPE, MODULEAPP, POSITION, SUBPOSITION, ELEMENTTYPE, KEYVALUE, 
VISIBLE, IMAGE, MAXMENUID, ROWSTAMP)  Values 
   ('MODULE', 'INVENTOR',10610, 0, 'APP', 'INVISSUE', 1, 
'appimg_invissue.gif', MAXMENUSEQ.NEXTVAL, '1671357'); 
 
COMMIT; 

 

Restart Maximo application server. 
 
Delete web browser cache (internet temporary files and cookies) from every computer that accesses Maximo. 
 
Try the problem scenario. 


 The Issues and Transfer app will now be visible and functional.

 

See ya

[{"Business Unit":{"code":"BU005","label":"IoT"}, "Product":{"code":"SSLKT6","label":"Maximo Asset Management"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"","Edition":""}]

UID

ibm11112739