Troubleshooting
Problem
Unable to log in to QRadar®, you receive the following message: "The host has been temporarily blocked due to many login attempts. Please try again later."
Symptom
You might see the following error message in the QRadar® UI:


Cause
Too many failed login attempts from the same host.
Environment
QRadar 7.3.2
Resolving The Problem
The error message is a result of too many failed login attempts, which is a security mechanism to avoid login abuse or a brute-force login attack. Restarting the tomcat service for the failed login attempts resets the QRadar® user accounts. Use the following command to restart tomcat:
systemctl restart tomcat
Warning: Restarting tomcat restarts the web server, which means all users are logged out temporarily, scheduled reports needing to be re-queued, and the web interface is unavailable momentarily.
Starting in QRadar® version 7.4.1 there are scripts that can be used from the console CLI to unlock users and hosts that have been blocked because of too many failed login attempts. This method does not restart the tomcat service. For information on how to run these scripts, see the following sections of documentation:
You can update the QRadar® authentication settings in the System Settings section of the Admin tab:
- Maximum Login Failures
- Login Failure Attempt Window (in minutes)
- Login Failure Block Time (in minutes)
- Login Host allowlist (comma separated)
Notes:
- Under the Admin > System Settings > Authentication Settings, you can configure the Login Failure Block Time to 0. This disables the Login Failure Block Time functionality for everyone.
- Under the Admin > System Settings > Authentication Settings > Login Host allowlist, you can create a allowlist of the host IP you want to exclude from the login failure block function of QRadar®.
- Any changes to the System Setting will require that you run a Deploy Changes.

Related Information
Document Location
Worldwide
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Document Information
Modified date:
14 January 2021
UID
ibm11108869