Troubleshooting
Problem
A data set fails to recall from an HSM migration volume although the data set's catalog entry indicates that the data set is migrated.
Symptom
The recall fails with message ARC1102I DATA SET IS NOT MIGRATED.
Cause
The catalog entry for the failing data set indicates that the data set is migrated. The MCD record in the HSM MCDS indicates the data set is not migrated.
Environment
DFSMShsm processing data set recall.
Diagnosing The Problem
Review the ISPF 3.4 'I' entry for the data set and verify that it is cataloged to 'MIGRAT'. If the data set is cataloged, issue the following command to determine whether an MCD record exists for the data set:
HSEND FIXCDS D user.data.set.name DISPLAY
If an MCD record is returned, inspect the first bit of the byte at offset x'6' in the MCD record. If the bit is on ('1'), HSM believes the data set is validly migrated. If the bit is off ('0'), HSM believes the data set was recently recalled. If the MCD record does not exist, HSM has no recent record of the data set.
The following command can also be used to determine whether or not the MCDS has record of a data set:
HLIST DS('dsname') MCDS
Resolving The Problem
Perform the following actions depending on the results of "Diagnosing The Problem":
MCD record does not exist.
This condition is commonly a result of previous maintenance or problems with the catalog or the HSM MCDS. Determine whether catalog or MCDS problems or maintenance occurred in the recent past. If so, consider catalog refresh or recovery, or MCDS recovery if the problem affects a significant number of data sets. Review logs and SMF records to determine the last time the affected data set was successfully used to help determine the root cause of the problem.
If the migrated data set itself still exists on an ML1 or ML2 volume and you know the volume it is on, or if the migrated data set still exists in the cloud tier, the AUDIT MEDIACONTROLS command can be used to rebuild the MCD record for the data set. With the MCD rebuilt, a subsequent recall should be successful. For assistance with the specific parameters to use on the AUDIT MEDIACONTROLS command, contact HSM support.
If the migrated data set no longer exists (or if its existence is unable to be determined), the catalog entry for the data set is effectively orphaned. To delete this orphaned catalog entry where the data set is cataloged to volser MIGRAT, use the instructions in the following technote:
MCD record exists, but it indicates the data set is no longer validly migrated. This condition indicates the data set was previously migrated, but HSM believes it was recently recalled. The MCD record indicates the volser of the primary volume where the data set was recalled to at offset x'40'. The time when the data set was recalled is at offset x'50', and the date the data set was recalled is at offset x'54'. Search the VTOC of the primary volume to see whether the data set resides on the volume. If so, recatalog the data set to the volume. If the data set cannot be found on the primary volume, review the SYSLOG, the HSM job logs, and the SMF records to determine actions taken against the data set after it was recalled.
The MCD record exists and the first bit at offset x'6' is on ('1'), indicating the data set is validly migrated. In this case, the data set's catalog entry and the HSM MCD record are in-sync and the ARC1102I message is unexpected. This condition can occur in an HSM environment employing the Common Recall Queue (CRQ), and a development, test, or sandbox system that has its own non-shared MCDS joins the CRQ. RECALL MWEs that are selected for processing by the rogue system fail with ARC1102I because the data set's MCD record does not exist in its MCDS. If this condition occurs, identify the rogue system and disconnect it from the HSMplex CRQ facility with the following command:
HSEND SETSYS COMMONQUEUE(RECALL(DISCONNECT))
Review the rogue HSM's ARCCMDxx parmlib member and remove any 'SETSYS COMMONQUEUE' entries to prevent joining the HSMplex CRQ at startup.
If the problem persists, notify IBM Support.
Document Location
Worldwide
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Document Information
Modified date:
10 July 2025
UID
ibm11106085