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Authentication error logging in to Content Analyzer

Troubleshooting


Problem

When logging in to IBM Business Automation Content Analyzer, the login fails with the message:

You are not authenticated properly, please verify your tenant information in the URL (tid and ont) and try again.

Symptom

The frontend log shows:
ERROR | (CIWCA00999): Internet connection timed out.
 

Cause

The browser is redirected to the backend service when logging in.  If the browser sees this site as separate from the frontend, the browser makes a separate check to see whether this certificate can be trusted.  Because of the redirection, the prompts are not provided to the user and the login fails.

Resolving The Problem

The browser must be manually told to accept the certificate.
  1. From an ssh client, log in to OpenShift and select the project if needed.
        oc login
        oc project <projectname>
  2. List the routing.
        oc get routes
  3. Copy the HOST/PORT for the spbackend service and paste it into the browser.
  4. Click through the browser warnings to accept the certificate.
  5. Verify that the browser shows 'WORKS!'
You can now log in through the Content Analyzer login page.

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSUM7G","label":"IBM Business Automation Content Analyzer on Cloud"},"Component":"","Platform":[{"code":"PF040","label":"RedHat OpenShift"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
28 October 2019

UID

ibm11099479