Troubleshooting
Problem
No flow data is being recieved by the QRadar Network Insights (QNI) appliance.
Symptom
QRadar Network Activity tab is unable to show flow data from the QRadar Network Insights (QNI) appliance.
Cause
A possible race condition (systems not starting in proper sequence) where
/opt/napatech3/config/ntservice.ini
is corrupted after a service restart.Diagnosing The Problem
- Use an SSH connection to the QNI host.
- Verify flow data is being NOT received by using the command:
/opt/napatech3/bin/monitoring
A message is displayed similar to:ntservice not running
- Using this command:
grep -i bonding /opt/napatech3/config/ntservice.ini
Search for a message similar to:
BondingType = *Separate*
BondingType = *Separate*
Note: Any similar messages indicate this configuration file is corrupted and the napatech3 service is not going to start.
Resolving The Problem
- Log in to the QNI appliance by using an SSH session.
- Move this file for investigation later by using the command:
mv /opt/napatech3/config/ntservice.ini /root/
yyyymmddntservice.ini and timestamp the copied file so we know when it is generated.
Note: The ntservice.ini file is re-created when the service restarts. - Restart the napatech3 service by using the command:
systemctl restart napatech3
- Test to confirm the service is now working by using the command:
grep -i bonding /opt/napatech3/config/ntservice.ini:
You should see messages similar to:
BondingType = Master
BondingType = Slave - Rerun the command
/opt/napatech3/bin/monitoring
to verify the service is running.
Results
The Napatech3 services are started and flow data is seen in QRadar Network Activity tab. If the service is still not running, open a case with QRadar Support.
The Napatech3 services are started and flow data is seen in QRadar Network Activity tab. If the service is still not running, open a case with QRadar Support.
Document Location
Worldwide
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Document Information
Modified date:
21 July 2022
UID
ibm11097679