Troubleshooting
Problem
In iBase, the Soft-delete has been activated, and some records have been deleted.
The user then wants to purge these soft-deleted records.
The folowing error is displayed :
Error #495 occurred in:
CDBRecord:Initialise
idDatabase:CDBRecord:Delete
FPurge:mPurgeRecords
Cause
This error is most probably caused by some inconsistency in the iBase database.
The solution is therefore to have iBase perform a consistency check of the data.
Resolving The Problem
Perform the following actions in iBase Designer, under Tools - Administration :
- do a Repair and Compact of the Database.
- do a Schema Integrity check
- Do a Link Integrity check
These actions will check that there is no inconsistency in the database. If there are inconsistencies, iBase will correct them.
Once this is done, you can retry the Purge deleted records.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
15 October 2019
UID
ibm11087450