IBM Support

Uploading Powercubes Cognos Analytics on Cloud 11.1.x

Question & Answer


Question

  • How to upload Cognos PowerCubes in a 11.1.x Cognos Analytics on Cloud (Dedicated) environment.

Cause

In release 11.1.x the PowerCube upload process has been updated with the following new features
  • Zip file support for uploading multi-part and time based cubes.
  • Ability to know when a PowerCube has been processed.
  • Ability to delete a PowerCube.

Answer

Pre-requisite:
SFTP to your cloud environment must have been set-up as part of your CA Cloud Onboarding process. If there are any problems with this please open a case with Support.
Transfer your PowerCube(s)
Using your SFTP solution, simply transfer the cube via SFTP to the /dropbox/powercubes folder.
What happens when a PowerCube uploaded.
When an upload of a PowerCube completes it is immediately processed. During this process it is copied or unarchived to a location that is shared with the CA report servers. Once the copy completes it is processed by PC activate which sets up the freshly copied cubes so they are available to be hot swamped by the CA report servers.
How to upload a multi-part partitioned PowerCube
With 11.1.x we now support uploading multi-part cubes as one zip file. The zip file should contain only the individual files that make up the multi-part PowerCube, no subfolders. 
How to upload a time based partitioned PowerCube
Create a zip file which contains the master cube the inventory file for the time base PowerCube and a subfolder with the cubes time based PowerCubes. 
How to know when a PowerCube has been processed and is ready for reporting.
PowerCubes are tagged with .processed extension created in the sftp powercubes folder after the cube has been made ready for reporting. 0 bytes means the cube has processed successfully.
How to delete a PowerCube that has been processed
Ability to delete a cube which has been processed without having to upload an empty cube file. Change the .processed tag to .delete this will trigger the process to delete the cube and its parts if it multi-part or time based from the cube reporting folder accessed by the CA Report Servers.
 

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6G84","label":"IBM Cognos Analytics on Cloud"},"Component":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"11.1.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
11 October 2019

UID

ibm11086465