IBM Support

Not able to upgrade JazzSM 1.1.3.0 due to missing files error

Troubleshooting


Problem

The installation logs at /var/ibm/InstallationManager/logs XML file show these errors:-
A problem occurred during the execution of the /opt/IBM/JazzSM/install/tip/tipWrapperInstall.xml file. 
ERROR: The following error occurred while executing this line: /opt/IBM/JazzSM/install/tip/tipWrapperInstall.xml:235: 
The following error occurred while executing this line: /opt/IBM/JazzSM/install/tip/tipWrapperInstall.xml:248: 
The following error occurred while executing this line: /opt/IBM/JazzSM/install/tip/tipInstall.xml:592: 

Problem creating zip: /opt/IBM/JazzSM/profile/config/cells/JazzSMNode01Cell/applications/isc.ear/deployments/isc/isclite.war/WEB-INF/isc.dir/ibmco/v-test1/cred.dat (No such file or directory) 
[/opt/IBM/JazzSM/install/tip/tipWrapperInstall.xml:215] A package has an issue that 
cannot be resolved by Installation Manager. Identify the package that has the issue by looking at the installation history.

Symptom

The JazzSM FP upgrade is not applied successfully.

Cause

It is found out that in customer server that this file exists but it is in folder "/ibmco\v-test1", the installer was not able to interpret this so it is looking for folder "/ibmco" and "/v-test1"

Resolving The Problem

Workaround is by creating the folder "ibmco" and "v-test1" and copied the cred.dat file. Then,perform the Update task again in Installation Manager.
Then,upgrade went successful with the workaround.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEKCU","label":"Jazz for Service Management"},"Component":"DASH upgrade","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"1.1.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

Jazzsm; Installation missing files;/

Document Information

Modified date:
23 March 2020

UID

ibm11086333