IBM Support

Security Bulletin: IBM Cognos Controller 2019Q4 Security Updater: Multiple Security Vulnerabilities have been identified in IBM Cognos Controller

Security Bulletin


Summary

This bulletin addresses several security vulnerabilities that are fixed in IBM Cognos Controller 10.4.1 IF2, 10.4.0 IF5, 10.3.1 IF12 and 10.3.0 FP1 IF13.

A vulnerability exists in IBM Cognos Controller that could allow an authenticated user to obtain sensitive information due to easy to guess session identifier names.

IBM Cognos Controller stores sensitive information in URL parameters. This may lead to information disclosure if unauthorized parties have access to the URLs via server logs, referrer header or browser history.

IBM Cognos Controller consumes Faster XML Jackson. A vulnerability exists in Faster XML Jackson-Databind that could be exploitable by an attacker.

Vulnerability Details

CVEID: CVE-2019-4411
DESCRIPTION: IBM Cognos Controller could allow an authenticated user to obtain sensitive information due to easy to guess session identifier names.
CVSS Base Score: 4.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/162658 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
 
CVEID: CVE-2019-4412
DESCRIPTION: IBM Cognos Controller stores sensitive information in URL parameters. This may lead to information disclosure if unauthorized parties have access to the URLs via server logs, referrer header or browser history.
CVSS Base Score: 3.7
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/162659 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)
 
CVEID: CVE-2019-12814
DESCRIPTION: FasterXML jackson-databind could allow a remote attacker to obtain sensitive information, caused by a polymorphic typing issue. By sending a specially-crafted JSON message, an attacker could exploit this vulnerability to read arbitrary local files on the server.
CVSS Base Score: 7.5
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/162875 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)

Affected Products and Versions

IBM Cognos Controller 10.4.1
IBM Cognos Controller 10.4.0
IBM Cognos Controller 10.3.1
IBM Cognos Controller 10.3.0

Remediation/Fixes

The recommended solution is to apply the applicable IBM Cognos Controller Interim Fix as soon as practical.
Please be advised , if you are a Cognos Controller 10.4.0 or 10.4.1 customer , the fixes for CVE-2019-4411 and CVE-2019-4412 are only available in 10.4.0 IF5 and 10.4.1 IF2. If you are a Cognos Controller 10.3.0 or 10.3.1 customer, all CVEs have been addressed in 10.3.0 FP1 IF13 and 10.3.1 IF12.
Cognos Controller Versions where each CVE has been addressed:
CVE 10.3.0 FP1 IF13 10.3.1 IF12 10.4.0 FP1 IF4 10.4.0 FP1 IF5 10.4.1 IF1 10.4.1 IF2
CVE-2019-4411 Y Y N Y N Y
CVE-2019-4412 Y Y N Y N Y
CVE-2019-12814 Y Y Y Y Y Y

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Change History

Update Published: November 8, 2019 (Revised Interim Fixes for versions 10.4.0 and 10.4.1))
Update Published: November 4, 2019
Original Version Published: October 25, 2019

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Internal Use Only

Advisory ID Product Record ID
16460 137347
16466 137359
16923 139132
 

Document Location

Worldwide

[{"Business Unit":{"code":"BU002","label":"Business Analytics"},"Product":{"code":"SS9S6B","label":"Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.1, 10.4.0, 10.3.1, 10.3.0","Edition":""}]

Document Information

Modified date:
21 November 2019

UID

ibm11086123