IBM Support

ITM Agent Insights: TCR 3.1.2.1 not able to use compatible mode for database access

Technical Blog Post


Abstract

ITM Agent Insights: TCR 3.1.2.1 not able to use compatible mode for database access

Body

This blog will help to resolve the error QE-DEF-0285, QE-DEF-0325, RQP-DEF-0068, UDA-SQL-0569, UDA-SQL-0571. Using Jazz for service management 1.1.2.1 and Tivoli Common Reporting 3.1.2.1 with Cognos 10.2.1 on RHE Linux Santiago you may have cataloged a remote database on the application server to use compatible mode, but the connection test for the datasource failed with following error code:

 

QE-DEF-0285 The logon failed.
QE-DEF-0325 The logon failed for the following reason:
RQP-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database(s) in:  testDataSourceConnection

UDA-SQL-0569 Unable to load the driver manager library ( libdb2.so ).
UDA-SQL-0571 The operating system returned an error message ( libpam.so.0: cannot open shared object file: No such file or directory ).
BME-EX-0144 Trace back: BmtPlayTransaction.cpp(788): QFException: CCL_RETHROW: BmtPlayTransaction::DoAction
BmtActionsHelper.cpp(488): QFException: CCL_RETHROW: BmtActionsHelper:: DoAction
QFSSession.cpp(1153): QFException: CCL_RETHROW: QFSSession:: ProcessDoRequest()
QFSSession.cpp(1151): QFException: CCL_CAUGHT: QFSSession:: ProcessDoRequest()
QFSSession.cpp(2045): QFException: CCL_RETHROW: QFSSession:: SessionProcessTestConnection()
Source/QE_RsApi.cpp(2089): QFException: CCL_RETHROW: QE
Source/QEI_ConnectionFault.cpp(814): QFException: CCL_THROW: QE

 

Possible solution for above errors are contained in the following technotes

 

http://www.ibm.com/support/docview.wss?uid=swg21461123
http://www.ibm.com/support/docview.wss?uid=swg21367256             
                                                                        

If you still have an issue after using the technotes above, it may be due to a missing 32bit library in the PATH and DB2DIR in script.

Normally you add the 32 bit path to the LIBPATH environment variable in the setTCRenv.sh script to resolve this issue.

To do this:

1) Edit this file JazzSM_Home/reporting/bin/setTCRenv.sh and add that same link to the 32 bit db2 libs, similiar to this one:

export LIBPATH=/opt/IBM/db2/V10.1/lib32:$LIBPATH

You may also need to do this. (not always required):

2) Edit this file <JazzSM_WAS_Profile>/bin/setupCmdLine.sh and add this line to the end of it, verify that the path is correct. Be sure and put the dot space before the start of the path:

. /opt/IBM/JazzSM/reporting/bin/setTCRenv.sh

 

 

 

 

image

 

Subscribe and follow us for all the latest information directly on your social feeds:

 

 

image

 

image

 

image

 

 

  



 

Check out all our other posts and updates:

Academy Blogs:https://goo.gl/U7cYYY
Academy Videos:https://goo.gl/TLfMoF
Academy Google+:https://goo.gl/HnTs0w
Academy Twitter :https://goo.gl/AhR8CL








 

 

 

[{"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Product":{"code":"","label":""},"Component":"","Platform":[{"code":"","label":""}],"Version":"","Edition":""}]

UID

ibm11084635