IBM Support

WAS Liberty Profile Server fails to start after configuring with ITCAM for DC v7.2 IF13.

Technical Blog Post


Abstract

WAS Liberty Profile Server fails to start after configuring with ITCAM for DC v7.2 IF13.

Body

Support for the WAS Liberty Profile was included in the DC v7.2 IF13 Fixpack available here. However, if you configure and then attempt to start the WAS Liberty Profile, you might not be able to start the server.  If you get an error message indicating that the am_ibm_14 file/library can't be found, then this can be easily fixed as follows:

* first look for your server.env file and make a backup of it, this file is usually in the ${WLP.install.directory}/etc or ${WLP.install.directory}/usr/servers/<serverName>

* after you find the file, open it and change the PATH variable.  Append the "win64" folder to your PATH as follows.  For example:

PATH=/lib;F:/IBM/ITM/dchome/7.2.0.0.13/toolkit/lib/win32;F:/IBM/ITM/dchome/7.2.0.0.13/toolkit/lib/win32/ttapi;/IBM/ITM/dchome/7.2.0.0.13/toolkit/lib/win64;/IBM/ITM/dchome/7.2.0.0.13/toolkit/lib/win64/ttapi

* save file and restart your Liberty profile/server.   Look in the messages log file and verify its started now.

Good luck. Smile

Noel Lewis

ITCAM / APM / ICAM L2 Support team

 

Tutorials Point

 

Subscribe and follow us for all the latest information directly on your social feeds:

 

 

image

 

image

 

image

 

 

  

Check out all our other posts and updates:

Academy Blogs:https://goo.gl/U7cYYY
Academy Videos:https://goo.gl/FE7F59
Academy Google+:https://goo.gl/Kj2mvZ
Academy Twitter :https://goo.gl/GsVecH


image

[{"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Product":{"code":"","label":""},"Component":"","Platform":[{"code":"","label":""}],"Version":"","Edition":""}]

UID

ibm11084437