IBM Support

APM Postgres agent requirements questions

Technical Blog Post


Abstract

APM Postgres agent requirements questions

Body

Questions:

1- can we work, without this extension (postgresql-contrib)? or it is mandatory?

2- what are the attributes that we will lose if we didn't install this extension?

3- If customer not aware with user/password , any workaround to create new user to work with?

4- * Share with IBM customer concern about the below:

I´m a little concerned about the utilities as they seem to be quite heavy weighing . If they are deployed like that we might have compatibility implications going forward. How is it guaranteed, that those get updated in a timely manner and do not impact us in any way when we update components?

5- Could you provide steps for installing the "postgresql-contrib"?

Answers:
Here are the answers to your questions.

1. The agent would work without the extension as well, it is not mandatory. But the agent would not collect data for the dependent KPIs.

2. Since we are using the extension to monitor SQL statistics, the attributes related to the following areas won't be available:

SQL Statistics: Data about count of SQL statements

SQL Statement Perf: Data about performance of SQL statements

SQL Response Time: Data about response time of the SQL statements

3. The agent can be configured with any PostgreSQL database user.

4. The extension is part of the official PostgreSQL package, and if required needs to be updated manually. Following articles cover the detailed steps:

https://www.postgresql.org/docs/10/sql-createextension.html

https://www.postgresql.org/docs/10/sql-alterextension.html

We have not come across any compatibility implications related to the extension.

5. Following are the steps for installing the postgresql-contrib package. Since the PostgreSQL sever version and platform are not known, the steps are assuming PostgreSQL v9.1 or later:

Depending on which Operating System, we are using we may need to install a separate package to use it.

1. Install PostgreSQL contrib package

Debian/Ubuntu:

# Replace 9.X with your installed Postgres version:

sudo apt-get install postgresql-contrib-9.X

RedHat/CentOS/SLES:

sudo yum install postgresql-contrib

2. Configure PostgreSQL

Add the following entries to your postgres.conf:

shared_preload_libraries = 'pg_stat_statements'

# Increase the max size of the query strings Postgres records

track_activity_query_size = 2048

# Track statements generated by stored procedures as well

pg_stat_statements.track = all

3. Restart the PostgreSQL daemon

sudo service postgresql restart

Alternatively, following links can be referred:

https://www.postgresql.org/docs/9.3/contrib.html

https://pganalyze.com/docs/install/01_enabling_pg_stat_statements

[{"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Product":{"code":"","label":""},"Component":"","Platform":[{"code":"","label":""}],"Version":"","Edition":""}]

UID

ibm11083195