IBM Support

"No stores" message when accessing WebSphere Commerce Accelerator

Troubleshooting


Problem

You try to access WebSphere Commerce Accelerator. After you enter your user name and password and click "Log On", you might see the following alert message: "There are currently no stores in the database."

Cause

Generally you would configure your port forward settings in a client like PuTTY to access cloud environments as documented in the following link:
http://www.ibm.com/support/knowledgecenter/SSWT7D_1.0.0/com.ibm.commercecloud.administering.doc/tasks/tad_connect_jumphosts_put.htm

After you configure the port, you would access WebSphere Commerce Accelerator with a URL similar to (the exact port number and hostname depends on your local configuration):
https://localhost:8000/accelerator


When you use the URL, you might notice the problem described when you try to log in.

After you ensure the database tables (STORE and STOREENT) do in fact contain store data, it can be assumed that the problem might be a result of your cookie-based session management configuration in wc-server.xml / <instance>.xml.

When you enable cookie-based session management, if you have also enabled domain-based restrictions, WebSphere Commerce will accept cookies only from the specified domain names. When the user ID switch occurs just before the requested URL is redirected to the second URL (StoreLanguageSelection), WebSphere Commerce might reject the cookies that are generated immediately following log in because it does not recognize the domain. As a result of the cookie rejection, WebSphere Commerce cannot identify the user who is associated with the request and thus cannot obtain the store details associated with the user.

Diagnosing The Problem

When you enable the following trace:
com.ibm.websphere.commerce.WC_TOOLSFRAMEWORK=all

You might notice the following output in trace.log:
WC_TOOLSFRAME 3 StoreLanguageBean init User: null
WC_TOOLSFRAME 3 StoreLanguageBean init No store in database.

Resolving The Problem

Following are two options to resolve the problem.

  1. Remove the domain-specific restrictions in your cookie-based session management configuration in wc-server.xml
    - or -
  2. Access WebSphere Commerce Accelerator with the fully qualified domain name (for example https://www.ibm.com:8000/accelerator) by adding an alias in your local 'hosts' configuration file.

[{"Product":{"code":"SSWT7D","label":"Commerce on Cloud"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"Enterprise","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
16 June 2018

UID

swg21987869