IBM Support

'No login methods supported' error

How To


Summary

'No login methods supported' error

Steps

When set up email connector, it failed to retrieve messages from an IMAP server and displays error messages like the following in the logs:

com.sun.mail.iap.ProtocolException: No login methods supported!

at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:668)[114:javax.mail:1.4.7]

at javax.mail.Service.connect(Service.java:295)[114:javax.mail:1.4.7]

at javax.mail.Service.connect(Service.java:176)[114:javax.mail:1.4.7]

at javax.mail.Service.connect(Service.java:125)[114:javax.mail:1.4.7]

Cause

The email connector need to configure the IMAP probably to be able to use TLS for non-SSL connections. If you connect to an IMAP server without using SSL, and the server is not configured to allow unencrypted connections, you may see the error shown above.

Resolution

You will need to set the irhub.mail.cfg correctly to use the right protocol for IMAP for the email connector.

Option 1:

Switch to using an SSL connection to communicate with your IMAP server.

imap_enablessl=true

imap_port=xxx e.g 993

imap_starttls=false

Option 2:

If you are connecting to your IMAP server over a non-SSL connection (using STARTTLS)

You need to set

imap_starttls=true

imap_enablessl=false

imap_port=xxx e.g 143

Here is the default port for IMAP & protocol:

IMAP Server (Incoming Messages) Non-Encrypted AUTH 143
Secure (TLS) StartTLS 143
Secure (SSL) SSL 993

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSIP9Q","label":"IBM Security SOAR"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
19 April 2021

UID

ibm11159528