IBM Support

NETSTAT PORTLIST is empty

Troubleshooting


Problem

When a NETSTAT PORTList/-o comand is issued, it reports that there are no port reservations. However, the TCPIP PROFILE lists several reservations within the PORT statement.

Symptom


   DISPLAY TCPIP,,NETSTAT,PORTLIST
   EZD0101I NETSTAT CS V1R13 TCPCS
   PORT# PROT USER     FLAGS    RANGE       SAF NAME
   0 OF 0 RECORDS DISPLAYED
   END OF THE REPORT

Cause

Any syntax error that occurs while processing the PORT statement will cause the whole statement to be rejected. If all of the reservations are listed in a single PORT statement, that error will result in no reserved ports in the stack.

Diagnosing The Problem

Review the messages issued during TCPIP startup for any errors while processing the PORT statement..

Resolving The Problem

Correct the error. Copy the corrected PORT statement to a separate file for use as an OBEYFILE input to immediately enable the intended reservations.

Related Information

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"--","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.6;1.7;1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2;2.3","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
15 June 2018

UID

swg21594896