Troubleshooting
Problem
This technote identifies a potential resolution to the error, Neither DSN nor SERVER keyword supplied - Unable to connect to the database, which might occur when creating an IBM® Rational® RequisitePro® project during database validation when using Microsoft® SQL Server as the database.
Cause
The full error message is as follows:
Neither DSN nor SERVER keyword supplied - Unable to connect to the database, Ensure that the configuration and account information are valid.
Although the connection test might be successful, this does not mean that all the information in the SQL configuration dialog boxes have been filled out properly.
This error is known to be the result of ignoring step 13 of the Configuring SQL Server for IBM Rational RequisitePro reference, under "Creating a project in SQL Server":
13. Click the check box Change the default database to and select a database name supplied by your database administrator, such as "RequisitePro." Click Next.
Resolving The Problem
To resolve this issue:
Click the checkbox Change the default database to and select the database name.
Note: This information is required, and can not be left blank.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21256443