IBM Support

NAV_300068: GUI hostname could not be fetched

Troubleshooting


Problem

Attempting to log in to Navigator for i returns "NAV_300068: GUI hostname could not be fetched". Navigator for i is unable to process the attempted logon. 

Cause

Navigator for i needs to make internal connections to the IBM i Host Servers on the system it is running on. To provide a more secure environment, Q1 2025 Navigator PTFs have changed the process Navigator for i uses to connect. Navigator now relies on the IBM i's TCP/IP Configuration to obtain its configured Domain Name and will attempt to connect to that. Improper TCP/IP Configurations can cause resolution attempts for that Domain Name to fail, causing the NAV_300068 error on logon attempts.

Diagnosing The Problem

Review the systems Domain Information configuration within CFGTCP opt 12. 
- Verify the correct Host Name and Domain Name are set correctly. The Fully Qualified Domain Name (FQDN) will be HostName.DomainName.
 
      Example:
           Host Name:  SystemA
           Domain Name:  IBM.COM
      FQDN is SystemA.IBM.COM
- Verify the Host Name Search Priority. This is an important step since it controls where the IBM i will look for DNS resolution first. 
If the Host Name Search Priority is set to *LOCAL, the IBM i will use the IBM i Host Table (CFGTCP opt 10) first. The IBM i will use the DNS servers tables second if details are not found in the IBM i Host Table. If the search priority is set to *REMOTE, the IBM i will use the configured DNS servers for DNS resolution first. 
- Confirm valid DNS servers are configured and accessible. DNS server entries that are invalid or not reachable can cause performance issues. 

Resolving The Problem

To correct the problem when the Host Name Search Priority set to *LOCAL, verify the IBM i Host Table has an entry for the systems FQDN as the first entry for the system's IP address. 
- Run CFGTCP and take option 10. Verify the FQDN is entered as the first entry for the systems IP address. The IBM i Host Name (i.e., short name) cannot be the first entry for the system's IP address. The FQDN must be listed first.
      Example:
      192.168.1.200           SystemA.IBM.COM  <--- FQDN listed first
                                              SystemA 
- Secondary suggestion, in the case where the IBM i resorts to using the configured DNS server(s) for resolution, make sure there is an entry for the IBM i FQDN pointing to the IBM i's IP address. This will only be used if the IBM i Host Table is improperly configured. 
To correct the issue when Host Name Search Priority is set to *REMOTE, verify that the correct DNS servers are configured and reachable. Also, assure that the configured DNS servers have a valid entry for the IBM i's FQDN pointing to the IBM i's IP address. 
- Run CFGTCP and take option 12. Verify the correct DNS server IP address(es) are set. Test connectivity to them by using PING X.X.X.X from an IBM i command line. If it is unreachable, there is a problem. 
- Verify the DNS server has a correct entry of the IBM i's FQDN pointing to the IBM i's IP address. 
If further assistance is needed, please open a support case to IBM i Support. Gathering an HTTP Admin Collector for review will be needed.

Document Location

Worldwide

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Document Information

Modified date:
23 June 2025

UID

ibm17237305