Question & Answer
Question
What do I collect for support if I'm diagnosing a performance problem with poor disk response times and the storage is VSCSI virtual disks from an IBM i Host?
Cause
After analyzing Collection Services, Job Watcher, PEX, etc. it is found that jobs are being slowed down by poor disk response times. Collection Services or a rack configuration show that the IOA type is a 290A and the disk resource type is one of the following based on the sector size presented to IBM i.
6B22-050: 512 byte
6B22-055: 520 byte
6B4E-050: 4096 byte
6B4E-055: 4160 byte
Answer
In this configuration there can be a variety of storage backing the virtual disks presented to IBM i. Everything from internal hard disk or solid state drives to fiber channel connected external storage. This document will describe what to collect from the IBM i guest(s) and host partitions, and for supported external storage devices that may be backing the disks on the i Host.
IBM i - Collect from guest(s) and host partitions
IBM i
1. Normal Collection Services, Job Watcher, PEX used to diagnose performance problems. This normally will have been collected during initial PD before it is determined the problem is with the disk subsystem. At a minimum Collection Services will be needed.
Master Data Collection document for IBM i Performance:
http://www-01.ibm.com/support/docview.wss?uid=nas8N1012115
2. PALs and LIC LOGs. This document describes how to collect SYSSNAP which is one method that can used to collect PALs (with hex and stats data) and VLOGs. Use this command and reference the document for more information on QMGTOOLS and SYSSNAP.
QMGTOOLS/SYSSNAP OUTPUT(*IFS) LICLOGS(Y) PALS(Y) QHST(Y) STRDATE(MMDDYY)
http://www-01.ibm.com/support/docview.wss?uid=nas8N1010353
3. Advacned Analysis Macros IODD and VIOFR
STRSST
Press the Enter key.
Sign in with a service tool profile and password that has authority to Display/Alter/Dump in SST.
Select Option 1 - Start a service tool, and press the Enter key.
Select Option 4 - Display/Alter/Dump, and press the Enter key.
Option 2 - Dump to printer, and press the Enter key.
Select Option 2 - Licensed Internal Code (LIC) data, and press the Enter key.
Select Option 14 - Advanced analysis, and press the Enter key.
Specify option 1 and type iodd, and press the Enter key
On the options screen type dumpalldebug and press the Enter key
Press the Enter key until the spool file is created
Press F12 until you are back on the Advanced Analysis screen
Specify option 1 and type VIOFR, press the enter key
On the options screen type -client -detail -fr -engine -login -bus -transporter -crq, press the enter key
Press then Enter key until the spool file is created
Back out of SST using F12
Send the two QPCSMPRT spool files to ECuRep.
If HDISKs are backed by external storage:
The most common switches are Brocade and Ciscso. The basic commands are included below, but check with your SAN team or switch documentation if assistance is required.
Brocade - supportsave
Cisco - show tech-support
Storage. It is important to collect snaps or state saves from the storage system during or as soon as possible after the performance problem has cleared. This will prevent important data from being wrapped out which typically can happen within one to two hours. Contact your Storage Administrator, IBM Storage Support, or Third party vendor for additional assistance or details.
2107 DS8000 Family: Collect a state save.
1. Generate a Statesave using DSCLI:
* Available in all Releases.
diagsi -action warmstart <Storage Image>
eg.
dscli> diagsi -action warmstart IBM.2107-xxxxxxx
Date/Time: May 5, 2015 6:48:46 PM BRT IBM DSCLI Version: 7.7.5.61 DS: IBM.2107-xxxxxxx
CMUD00023W diagsi: Are you sure you want to perform diagnostic control warmstart? [y/n]:y
CMUD00026I diagsi: Diagnostic control warmstart is successfully submitted. It will take some time for the system to complete the request.
-- or --
1. Generate an ODD Dump using DSCLI:
* Available on R7.3+ .
diagsi -action odd <Storage Image>
2. After these have been produced, DS8000 hardware support needs to dial in to the box and offload the files generated.
D840 - IBM Flash Systems
Download the Support Package containing standard logs using the Flash Systems GUI.
Contact Flash Systems Support for details.
D910 - EMC
Contact EMC Support or documentation for details.
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Document Information
Modified date:
18 December 2019
UID
nas8N1022541