IBM Support

multitool syncreplica -import fails with "Trouble communicating with VOB database: xxx"

Troubleshooting


Problem

When trying to import an IBM® Rational® ClearCase MultiSite® packet using []multitool syncreplica -import[], the operation fails with []db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer[].

Symptom

When trying to run the command, multitool syncreplica -import, it reports the following error:

db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
multitool: Error: Trouble communicating with VOB database: "/vobs/ezx_apps".
multitool: Error: Trouble opening VOB database: "/vobs/ezx_apps".
multitool: Error: Unable to access epoch information for vob /vobs/ezx_apps
.

Additional symptoms include:

  • Attempts to change directory (cd) into the VOB root also fails with I/O Error and communication timeout error

  • multitool lsreplica reports:

    multitool lsreplica -invob /vobs/ezx_apps                              
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    multitool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    multitool: Error: Trouble opening VOB database: "/vobs/ezx_apps".

  • Running checkvob on the import VOB reports errors:
                                                       
    cleartool checkvob -global vob:/vobs/ezx_apps                                                                      
    The session's log file is "checkvob.05-Nov-07.11:15:24".                
    Starting analysis of Admin VOB hierarchy.                              
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    cleartool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    cleartool: Error: Trouble opening VOB database: "/vobs/ezx_apps".      
    Starting "global type" processing.                                      
    Detection of eclipsing local copies is: ENABLED                        
    Detection of protection mis-matches is: ENABLED                        
    Detection of eclipsing local locks is: ENABLED                          
    Correction of detected errors is: DISABLED                              
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    cleartool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    cleartool: Error: Trouble opening VOB database: "/vobs/ezx_apps".      
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    cleartool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    cleartool: Error: Trouble opening VOB database: "/vobs/ezx_apps".      
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    cleartool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    cleartool: Error: Trouble opening VOB database: "/vobs/ezx_apps".      
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    cleartool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    cleartool: Error: Trouble opening VOB database: "/vobs/ezx_apps".      
    db_open_db_V3: RPC: Unable to receive; errno = Connection reset by peer
    cleartool: Error: Trouble communicating with VOB database:              
    "/vobs/ezx_apps".                                                      
    Check database log on VOB host "az10vbs15.sat.mot.com".                
    cleartool: Error: Trouble opening VOB database: "/vobs/ezx_apps".      


  • The albd_log contains the following messages:

    11/12/07 10:02:04 albd_server(3244): Server db_server(4998) exited due to signal 6
    11/12/07 10:02:03 albd_server(3244): Server db_server(4997) exited due to signal 6

  • Running dbcheck usually does not report any errors.

Cause


Possible causes for this behavior are:

  1. There is corruption in the vista files in the VOB's db directory

  2. There is a hung db_server process

  3. The issue can be related to the defect, APAR PK32214, if a key file in the VOB's database directory has exceeded 32 GB

Resolving The Problem


  • Use these steps to address vista file corruption:

    1. Unmount the VOB

    2. Rename all vista files to vista_old.taf , vista_old.tcf and vista_old.tjf

    3. Kill the vob_server process

    4. Mount the VOB

    Note: If the above steps do not help, try restarting ClearCase or restarting the actual server

  • Refer to technote 1250896 for information about the various symptoms and fix for the defect

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Synchronization","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF015","label":"IRIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21289049