Troubleshooting
Problem
After a long period of inactivity, such as overnight, the first attempt of the bindings to connect to MQ results in the following error: MQJMS1107: A problem with the connection has occurred.
Symptom
The first message sent by the bindings to MQ after a period of inactivity results in the following error:
MQJMS1107: A problem with the connection has occurred.
J2CA0056I: The Connection Manager received a fatal connection error from the Resource Adapter for resource
JMS$ModuleName.MQ_Import_Module_MQIMPORT_CF$JMSManagedConnection@1.
The exception is: javax.jms.JMSException: MQJMS2008: failed to open MQ queue 'QUEUENAME'.
Subsequent messages work correctly.
Cause
The cause of this issue is a stale connection.
Resolving The Problem
To resolve this issue, complete the following steps in the administrative console:
- Navigate to Resources > JMS > Connection Factories > connection_ factory_name.
See Pic1.JPG at the bottom of this document for a visual representation of this administrative console panel.
- On the right side of the panel, click Connection pool.
See Pic2.JPG at the bottom of this document for a visual representation of this administrative console panel.
- Specify 0 in the Minimum connections field.
- Specify a value in the Unused timeout field to a value that is less than the values for the idle timeout or the network timeout.
This action causes the system to purge the unused connections and create a new connection for the first request after the long delay instead of it trying to use a stale connection.
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Document Information
Modified date:
15 June 2018
UID
swg21501969