IBM Support

Missing Task Pane after launching IBM i2 Analyst's Notebook

Troubleshooting


Problem

When using IBM i2 Analyst's Notebook, the Task Pane may not appear or load properly.

Symptom

The Task Pane that holds almost all the functions of Analyst's Notebook does not appear when launching Analyst's Notebook. This Task Pane normally appears on the right side of the application window. The Task Pane may also appear, but will be empty.

Cause

This issue can occur when the DLL library files do not load, have conflicted with other software, or have not registered correctly with the system. Analyst's Notebook may have worked without issue in the past, but now may experience this issue.

Environment

Microsoft Windows Operating System
IBM i2 Analyst's Notebook

Diagnosing The Problem

Other attempts to correct the issue do not work, such as verifying plug-in has loaded properly or performing a Repair of the installation via the Control Panel. Normal uninstall and reinstall procedures may not work.

Resolving The Problem

While a standard uninstall / reinstall of the product may not correct the issue, a more thorough removal of the software may be needed to get rid of residual files and settings that might be causing the issue. To perform a complete Uninstall and Reinstall of IBM i2 Analyst's Notebook, execute the following steps:

  1. Ensure all IBM i2 applications are closed.
  2. Uninstall all IBM i2 products that are associated with Analyst's Notebook, utilizing the Add/Remove Programs feature of the Control Panel.
  3. Run the Registry Editor application by going to the Start menu and type "regedit.exe" (no quotes) into the Search bar and select "regedit.exe" from the results list.
  4. Once the Registry Editor is open, navigate to the following location:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2

      Beneath the i2 Folder there will be multiple entries for Analyst's Notebook. If Analyst's Notebook is the ONLY IBM i2 application installed, you may delete the ENTIRE i2 folder by selecting it and pressing the DELETE key on the keyboard.

      If IBM i2 Analyst's Notebook is NOT the only IBM i2 application, only delete the following by selecting each one individually and pressing DELETE on the keyboard:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Analysis Repository
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Analysis Repository Tools
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Analyst's Notebook 7
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Online iLink 7
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Schema Designer

      The above entries may or may not exist after uninstalling via the Control Panel. If they are not present, that is okay. Just delete the ones that still exist.
  5. Delete the following folders on the C:\ drive if they still exist:
    C:\Program Files (x86)\i2 Analyst's Notebook 8
    C:\Program Files (x86)\IBM i2 Analysis Repository Connector 8
    C:\Program Files (x86)\IBM i2 Analysis Repository Tools 3
    C:\Program Files (x86)\IBM i2 Local Analysis Repository 3
    C:\Users\IBM_ADMIN\AppData\Local\IBM i2 (deleting this only affects Analyst's Notebook and no other IBM i2 applications, safe to delete entire folder) **NOTE**
    The final folder may be hidden and will require you to manually type the location into the Windows Explorer address bar at the top of the window.
  6. Restart the computer.
  7. Reinstall the software as usual making sure to right click the "Setup.exe" file and choose "Run as Administrator". Even though you may be listed or logged in as an Admin, this is still required to ensure all components are installed completely.
  8. Test the software for functionality and verify that the issue has been corrected.

[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;8.0;8.5;8.7;8.9;8.9.1;8.9.11;8.9.3;8.9.5;8.9.7;8.9.9","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21903674