IBM Support

Missing IBM Cognos toolbar button in Excel

Troubleshooting


Problem

Client launched Excel after it had crashed and no longer see the IBM Cognos tool bar button that should be available for Cognos Anaylsis for Excel

Symptom

Suggestion: Provide the full text transcript of the error. Include any "Steps to reproduce" this issue in this section.

Cause

Excel disabled the Active Application Add-In during last usage of Excel that caused the program to shut down.

Environment

Windows 2008
Excel 2007

Diagnosing The Problem

In Excel Add-Ins under Active Application Add-Ins there should be the following two add-ins listed:

Cognos Office for Excel
IBM Cognos Office for Excel 2007/2010

Under Inactive Application Add-Ins there should be the following add-in listed:

CognosOfficeUDF.Connect

If these are missing or disabled you will need to enable or manually add.

Resolving The Problem

Steps To Enable a disabled Add-In

1. Launch Excel
2. Select File/MS office button > Options > Add-Ins
3. Under the section titled Disabled Application, identify the add-in that you want to enable
4. Select the Add-in type of disabled in the Manage box and then click Go.
5. Select or clear the check box for the Add-in that you want enable and then click OK.

Steps to Add IBM Cognos Office for Excel 2007/2010 Add-In

1. Launch Excel
2. Select File/MS office button > Options > Add-Ins
3. In the Manage box select the Add-in type of COM Add-ins and then click Go.
5. Select or the check box for the Add-in that you want or select Add to browse to CognosOfficeShim12.dll under the CAFE install and then click OK.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Analysis for Microsoft Excel","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21663294